aboutsummaryrefslogtreecommitdiffstats
path: root/metis/documentation/Makefile.am
diff options
context:
space:
mode:
authormichele papalini <micpapal+fdio@cisco.com>2017-02-23 17:01:34 +0100
committerMichele Papalini <micpapal+fdio@cisco.com>2017-02-23 17:23:19 +0000
commitc580a00aac271a524e5a75b35f4b91c174ed227b (patch)
treefeddc15a9f1a4eb319d950f8d6330ac2b91e3d99 /metis/documentation/Makefile.am
parent9b30fc10fb1cbebe651e5a107e8ca5b24de54675 (diff)
Initial commit: sb-forwarder, metis.
Change-Id: I65ee3c851a6901929ef4417ad80d34bca0dce445 Signed-off-by: michele papalini <micpapal+fdio@cisco.com>
Diffstat (limited to 'metis/documentation/Makefile.am')
-rw-r--r--metis/documentation/Makefile.am33
1 files changed, 33 insertions, 0 deletions
diff --git a/metis/documentation/Makefile.am b/metis/documentation/Makefile.am
new file mode 100644
index 00000000..b11c8010
--- /dev/null
+++ b/metis/documentation/Makefile.am
@@ -0,0 +1,33 @@
+#
+# Copyright (c) 2017 Cisco and/or its affiliates.
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at:
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+#
+
+include ../config.mk
+
+SUBDIRS = manpage-source manpage
+
+docs: doxygen-metis
+
+doxygen-metis: metis.doxygen
+ ${DOXYGEN_BIN} -s metis.doxygen
+ ${LONGBOW_DOXYGEN_BIN_REPORT} -a --doxygenlog metis-doxygen.log
+
+website: longbow.log
+ $(MAKE) -C Jekyll
+
+# The Doxygen output directory removed here is set in metis.doxygen
+clobber: clean
+ ${RM} -rf metis-documentation
+
+CLEANFILES=metis-doxygen.log