aboutsummaryrefslogtreecommitdiffstats
path: root/apps/producers/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'apps/producers/CMakeLists.txt')
-rwxr-xr-xapps/producers/CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/apps/producers/CMakeLists.txt b/apps/producers/CMakeLists.txt
index 9259394e..37366362 100755
--- a/apps/producers/CMakeLists.txt
+++ b/apps/producers/CMakeLists.txt
@@ -17,6 +17,14 @@ cmake_minimum_required(VERSION 3.2)
set(PRODUCER_SOURCE_FILES
icnet_producer_test.cc)
+set(PRODUCER_HELLO_WORLD_SOURCE_FILES
+ icnet_producer_hello_world.cc)
+
add_executable(producer-test ${PRODUCER_SOURCE_FILES})
+add_executable(producer-hello-world ${PRODUCER_HELLO_WORLD_SOURCE_FILES})
+
target_link_libraries(producer-test icnet ${CMAKE_THREAD_LIBS_INIT} ${Boost_LIBRARIES})
+target_link_libraries(producer-hello-world icnet ${CMAKE_THREAD_LIBS_INIT} ${Boost_LIBRARIES})
+
install(TARGETS producer-test DESTINATION ${CMAKE_INSTALL_PREFIX}/bin COMPONENT library)
+install(TARGETS producer-hello-world DESTINATION ${CMAKE_INSTALL_PREFIX}/bin COMPONENT library)