aboutsummaryrefslogtreecommitdiffstats
path: root/cicn-plugin/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'cicn-plugin/CMakeLists.txt')
-rwxr-xr-xcicn-plugin/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/cicn-plugin/CMakeLists.txt b/cicn-plugin/CMakeLists.txt
index b9bcfd83..2836a044 100755
--- a/cicn-plugin/CMakeLists.txt
+++ b/cicn-plugin/CMakeLists.txt
@@ -155,13 +155,13 @@ if (DEB_PACKAGE)
SET(TYPE "DEBIAN")
SET(GENERATOR "DEB")
SET(CPACK_PACKAGE_FILE_NAME "${PACKAGE_NAME}_${PACKAGE_VERSION}_${ARCHITECTURE}")
- SET(CPACK_${TYPE}_PACKAGE_DEPENDS "vpp (>> 17.01), vpp-lib (>> 17.01)")
+ SET(CPACK_${TYPE}_PACKAGE_DEPENDS "vpp (>= 17.04), vpp (< 17.07), vpp-lib (>= 17.04), vpp-lib (< 17.07), vpp-plugins (>= 17.04), vpp-plugins (< 17.07)")
elseif (RPM_PACKAGE)
SET(TYPE "RPM")
SET(GENERATOR "RPM")
SET(CPACK_PACKAGE_FILE_NAME "${PACKAGE_NAME}-${PACKAGE_VERSION}.${ARCHITECTURE}")
SET(CPACK_RPM_EXCLUDE_FROM_AUTO_FILELIST_ADDITION "/usr/etc" "/usr/lib/python2.7" "/usr/lib/python2.7/site-packages")
- SET(CPACK_${TYPE}_PACKAGE_REQUIRES "vpp > 17.01, vpp-lib > 17.01")
+ SET(CPACK_${TYPE}_PACKAGE_REQUIRES "vpp >= 17.04, vpp < 17.07, vpp-lib >= 17.04, vpp-lib < 17.07, vpp-plugins >= 17.04, vpp-plugins < 17.07")
else ()
RETURN()
endif ()