aboutsummaryrefslogtreecommitdiffstats
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog6
-rw-r--r--debian/control12
-rw-r--r--debian/netmon.postinst2
-rw-r--r--debian/python3-netmodel.postinst3
-rwxr-xr-xdebian/rules2
-rw-r--r--debian/vicn.postinst3
6 files changed, 11 insertions, 17 deletions
diff --git a/debian/changelog b/debian/changelog
index 90590ffb..cc91eb40 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,5 +1,5 @@
-vicn (1.0-25~g009e5b9~b1) UNRELEASED; urgency=medium
+vicn (0.1-1) UNRELEASED; urgency=medium
- * Initial release (Closes: #nnnn)
+ * Initial release. (Closes: #XXXXXX)
- -- Mauro Sardara <mauro.sardara@cisco.com> Tue, 18 Oct 2016 12:10:07 +0200
+ -- <testing@icn-ucs-1.cisco.com> Mon, 10 Jul 2017 11:07:54 +0200
diff --git a/debian/control b/debian/control
index 1dad2688..99e51ee9 100644
--- a/debian/control
+++ b/debian/control
@@ -1,5 +1,4 @@
Source: vicn
-Version: 3.23
Section: python
Priority: optional
Maintainer: Jordan Augé <jordan.auge@cisco.com>
@@ -11,7 +10,6 @@ Vcs-Browser: https://gerrit.fd.io/r/gitweb?p=cicn.git
X-Python3-Version: >= 3.5
Package: python3-netmodel
-Version: 3.23
Architecture: all
Depends: ${python3:Depends}, ${misc:Depends}, python3-daemon, python3-lockfile, python3-setuptools, python3-pip
Suggests: python-netmodel-doc
@@ -19,15 +17,13 @@ Description: Netmodel
Netmodel
Package: netmon
-Version: 3.23
Architecture: all
-Depends: ${python3:Depends}, ${misc:Depends}, python3-netmodel
+Depends: ${python3:Depends}, ${misc:Depends}, python3-netmodel, bwm-ng
Suggests: netmon-doc
Description: Monitoring
Monitoring daemon
Package: vicn
-Version: 3.23
Architecture: all
Depends: ${python3:Depends}, ${misc:Depends}, python3-netmodel
Suggests: vicn-doc
@@ -51,9 +47,3 @@ Description: vICN experiment controller
The master, vICN, controls the whole cluster of servers, by means of HTTPS REST
APIs and remote SSH.
-#Package: vicn-resource-hicn
-#Architecture: all
-#Depends: vicn
-#Description: TODO
-# TODO
-
diff --git a/debian/netmon.postinst b/debian/netmon.postinst
index fdbfb95e..41df34c0 100644
--- a/debian/netmon.postinst
+++ b/debian/netmon.postinst
@@ -1,3 +1,3 @@
#!/bin/bash
-pip3 install --upgrade autobahn
+pip3 install --upgrade pylxd
diff --git a/debian/python3-netmodel.postinst b/debian/python3-netmodel.postinst
new file mode 100644
index 00000000..587f14b0
--- /dev/null
+++ b/debian/python3-netmodel.postinst
@@ -0,0 +1,3 @@
+#!/bin/bash
+
+pip3 install --upgrade autobahn pyopenssl pylxd
diff --git a/debian/rules b/debian/rules
index 86a95b03..14bba467 100755
--- a/debian/rules
+++ b/debian/rules
@@ -8,8 +8,6 @@
%:
dh $@ --with python3,sphinxdoc --buildsystem=pybuild
-override_dh_auto_test:
-
#override_dh_auto_build: export http_proxy=127.0.0.1:9
#override_dh_auto_build: export https_proxy=127.0.0.1:9
#override_dh_auto_build: dh_auto_build
diff --git a/debian/vicn.postinst b/debian/vicn.postinst
new file mode 100644
index 00000000..41df34c0
--- /dev/null
+++ b/debian/vicn.postinst
@@ -0,0 +1,3 @@
+#!/bin/bash
+
+pip3 install --upgrade pylxd