aboutsummaryrefslogtreecommitdiffstats
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog5
-rw-r--r--debian/compat1
-rw-r--r--debian/control59
-rw-r--r--debian/netmon.install5
-rw-r--r--debian/netmon.postinst3
-rw-r--r--debian/python3-netmodel.install1
-rwxr-xr-xdebian/rules17
-rw-r--r--debian/vicn.install3
-rw-r--r--debian/watch3
9 files changed, 97 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
new file mode 100644
index 00000000..90590ffb
--- /dev/null
+++ b/debian/changelog
@@ -0,0 +1,5 @@
+vicn (1.0-25~g009e5b9~b1) UNRELEASED; urgency=medium
+
+ * Initial release (Closes: #nnnn)
+
+ -- Mauro Sardara <mauro.sardara@cisco.com> Tue, 18 Oct 2016 12:10:07 +0200
diff --git a/debian/compat b/debian/compat
new file mode 100644
index 00000000..ec635144
--- /dev/null
+++ b/debian/compat
@@ -0,0 +1 @@
+9
diff --git a/debian/control b/debian/control
new file mode 100644
index 00000000..1dad2688
--- /dev/null
+++ b/debian/control
@@ -0,0 +1,59 @@
+Source: vicn
+Version: 3.23
+Section: python
+Priority: optional
+Maintainer: Jordan Augé <jordan.auge@cisco.com>
+Build-Depends: debhelper (>= 9), dh-python, python3-all, python3-setuptools, python3-docutils, python3-sphinx
+Standards-Version: 3.9.5
+Homepage: https://wiki.fd.io/view/Vicn
+Vcs-Git: https://gerrit.fd.io/r/cicn
+Vcs-Browser: https://gerrit.fd.io/r/gitweb?p=cicn.git
+X-Python3-Version: >= 3.5
+
+Package: python3-netmodel
+Version: 3.23
+Architecture: all
+Depends: ${python3:Depends}, ${misc:Depends}, python3-daemon, python3-lockfile, python3-setuptools, python3-pip
+Suggests: python-netmodel-doc
+Description: Netmodel
+ Netmodel
+
+Package: netmon
+Version: 3.23
+Architecture: all
+Depends: ${python3:Depends}, ${misc:Depends}, python3-netmodel
+Suggests: netmon-doc
+Description: Monitoring
+ Monitoring daemon
+
+Package: vicn
+Version: 3.23
+Architecture: all
+Depends: ${python3:Depends}, ${misc:Depends}, python3-netmodel
+Suggests: vicn-doc
+Description: vICN experiment controller
+ = vICN
+ .
+ == Description
+ .
+ This application is an ICN experimental testbed orchestrator. It allows to
+ quickly deploy experiments in a cluster using linux containers, IP tunnels and
+ linux kernel tools.
+ .
+ This tool provides the following features:
+ .
+ - Physical topology deployment
+ - Virtual topology deployment
+ - ICN Network setup
+ - Management tools
+ .
+ The architecture of this orchestrator is basically a master-slave architecture.
+ The master, vICN, controls the whole cluster of servers, by means of HTTPS REST
+ APIs and remote SSH.
+
+#Package: vicn-resource-hicn
+#Architecture: all
+#Depends: vicn
+#Description: TODO
+# TODO
+
diff --git a/debian/netmon.install b/debian/netmon.install
new file mode 100644
index 00000000..98465421
--- /dev/null
+++ b/debian/netmon.install
@@ -0,0 +1,5 @@
+/etc/init/netmon.conf
+/lib/systemd/system/netmon.service
+/usr/lib/python3*/dist-packages/netmon
+/usr/lib/python3*/dist-packages/netmon-*.egg-info
+/usr/bin/netmon
diff --git a/debian/netmon.postinst b/debian/netmon.postinst
new file mode 100644
index 00000000..fdbfb95e
--- /dev/null
+++ b/debian/netmon.postinst
@@ -0,0 +1,3 @@
+#!/bin/bash
+
+pip3 install --upgrade autobahn
diff --git a/debian/python3-netmodel.install b/debian/python3-netmodel.install
new file mode 100644
index 00000000..5545c4af
--- /dev/null
+++ b/debian/python3-netmodel.install
@@ -0,0 +1 @@
+/usr/lib/python3*/dist-packages/netmodel/
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 00000000..86a95b03
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,17 @@
+#! /usr/bin/make -f
+
+#export DH_VERBOSE = 1
+
+# NOTE: setting PYBUILD_NAME breaks dh_install
+#export PYBUILD_NAME = vicn
+
+%:
+ dh $@ --with python3,sphinxdoc --buildsystem=pybuild
+
+override_dh_auto_test:
+
+#override_dh_auto_build: export http_proxy=127.0.0.1:9
+#override_dh_auto_build: export https_proxy=127.0.0.1:9
+#override_dh_auto_build: dh_auto_build
+# PYTHONPATH=. sphinx-build -N -bhtml docs/ build/html # HTML generator
+# PYTHONPATH=. sphinx-build -N -bman docs/ build/man # Manpage generator
diff --git a/debian/vicn.install b/debian/vicn.install
new file mode 100644
index 00000000..4325084c
--- /dev/null
+++ b/debian/vicn.install
@@ -0,0 +1,3 @@
+/usr/lib/python3*/dist-packages/vicn/
+/usr/lib/python3*/dist-packages/vicn-*.egg-info
+/usr/bin/vicn
diff --git a/debian/watch b/debian/watch
new file mode 100644
index 00000000..a4eda3e7
--- /dev/null
+++ b/debian/watch
@@ -0,0 +1,3 @@
+version=3
+opts=uversionmangle=s/(rc|a|b|c)/~$1/ \
+https://pypi.debian.net/mypackage/mypackage-(.+)\.(?:zip|tgz|tbz|txz|(?:tar\.(?:gz|bz2|xz)))