aboutsummaryrefslogtreecommitdiffstats
path: root/libccnx-common/ccnx/common/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'libccnx-common/ccnx/common/CMakeLists.txt')
-rw-r--r--libccnx-common/ccnx/common/CMakeLists.txt14
1 files changed, 7 insertions, 7 deletions
diff --git a/libccnx-common/ccnx/common/CMakeLists.txt b/libccnx-common/ccnx/common/CMakeLists.txt
index 34e71e79..3f21b095 100644
--- a/libccnx-common/ccnx/common/CMakeLists.txt
+++ b/libccnx-common/ccnx/common/CMakeLists.txt
@@ -257,13 +257,13 @@ foreach(lib ${libccnx_commonLibraries})
set_property(TARGET ${lib} PROPERTY C_STANDARD 99)
endforeach()
-install(FILES ${CORE_HDRS} DESTINATION include/ccnx/common )
-install(FILES ${INTERNAL_HDRS} DESTINATION include/ccnx/common/internal )
-install(FILES ${VALIDATION_HDRS} DESTINATION include/ccnx/common/validation )
-install(FILES ${CODEC_HDRS} DESTINATION include/ccnx/common/codec )
-install(FILES ${TESTDATA_HDRS} DESTINATION include/ccnx/common/codec/testdata )
-install(FILES ${SCHEMAV1_HDRS} DESTINATION include/ccnx/common/codec/schema_v1 )
-install(FILES ${SCHEMAV1_TESTDATA_HDRS} DESTINATION include/ccnx/common/codec/schema_v1/testdata )
+install(FILES ${CORE_HDRS} DESTINATION ${CMAKE_INSTALL_PREFIX}/include/ccnx/common )
+install(FILES ${INTERNAL_HDRS} DESTINATION ${CMAKE_INSTALL_PREFIX}/include/ccnx/common/internal )
+install(FILES ${VALIDATION_HDRS} DESTINATION ${CMAKE_INSTALL_PREFIX}/include/ccnx/common/validation )
+install(FILES ${CODEC_HDRS} DESTINATION ${CMAKE_INSTALL_PREFIX}/include/ccnx/common/codec )
+install(FILES ${TESTDATA_HDRS} DESTINATION ${CMAKE_INSTALL_PREFIX}/include/ccnx/common/codec/testdata )
+install(FILES ${SCHEMAV1_HDRS} DESTINATION ${CMAKE_INSTALL_PREFIX}/include/ccnx/common/codec/schema_v1 )
+install(FILES ${SCHEMAV1_TESTDATA_HDRS} DESTINATION ${CMAKE_INSTALL_PREFIX}/include/ccnx/common/codec/schema_v1/testdata )
#add_subdirectory(test)
#add_subdirectory(validation/test)