aboutsummaryrefslogtreecommitdiffstats
path: root/libccnx-common/documentation/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'libccnx-common/documentation/CMakeLists.txt')
-rw-r--r--libccnx-common/documentation/CMakeLists.txt8
1 files changed, 4 insertions, 4 deletions
diff --git a/libccnx-common/documentation/CMakeLists.txt b/libccnx-common/documentation/CMakeLists.txt
index e18939fa..1f3d722d 100644
--- a/libccnx-common/documentation/CMakeLists.txt
+++ b/libccnx-common/documentation/CMakeLists.txt
@@ -6,10 +6,10 @@ if(DOXYGEN_FOUND)
configure_file(libccnx-stage1.doxygen.in config.doxygen @ONLY)
configure_file(libccnx-stage2.doxygen.in config2.doxygen @ONLY)
- install(DIRECTORY images/ DESTINATION ${CMAKE_INSTALL_PREFIX}/share/libccnx-common/images)
- install(DIRECTORY doxygen-extras/ DESTINATION ${CMAKE_INSTALL_PREFIX}/share/libccnx-common/doxygen-extras)
- install(DIRECTORY examples/ DESTINATION ${CMAKE_INSTALL_PREFIX}/share/libccnx-common/examples)
- install(FILES DoxygenLayout.xml DESTINATION ${CMAKE_INSTALL_PREFIX}/share/libccnx-common)
+ install(DIRECTORY images/ DESTINATION ${CMAKE_INSTALL_PREFIX}/share/libccnx-common/images COMPONENT documentation)
+ install(DIRECTORY doxygen-extras/ DESTINATION ${CMAKE_INSTALL_PREFIX}/share/libccnx-common/doxygen-extras COMPONENT documentation)
+ install(DIRECTORY examples/ DESTINATION ${CMAKE_INSTALL_PREFIX}/share/libccnx-common/examples COMPONENT documentation)
+ install(FILES DoxygenLayout.xml DESTINATION ${CMAKE_INSTALL_PREFIX}/share/libccnx-common COMPONENT documentation)
set(HTML_PATH ${CMAKE_CURRENT_BINARY_DIR}/generated-documentation/html)