aboutsummaryrefslogtreecommitdiffstats
path: root/libccnx-portal/documentation/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'libccnx-portal/documentation/CMakeLists.txt')
-rw-r--r--libccnx-portal/documentation/CMakeLists.txt20
1 files changed, 20 insertions, 0 deletions
diff --git a/libccnx-portal/documentation/CMakeLists.txt b/libccnx-portal/documentation/CMakeLists.txt
new file mode 100644
index 00000000..13a839ad
--- /dev/null
+++ b/libccnx-portal/documentation/CMakeLists.txt
@@ -0,0 +1,20 @@
+find_package(Doxygen)
+
+if(DOXYGEN_FOUND)
+ configure_file(libccnx_api_portal-stage1.doxygen.in libccnx_api_portal-stage1.doxygen @ONLY)
+ configure_file(libccnx_api_portal-stage2.doxygen.in libccnx_api_portal-stage2.doxygen @ONLY)
+ add_custom_target(docs
+ DEPENDS doctags documentation)
+ add_custom_target(doctags
+ ${DOXYGEN_EXECUTABLE} ${CMAKE_CURRENT_BINARY_DIR}/libccnx_api_portal-stage1.doxygen
+ WORKING_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}
+ COMMENT "Generating Doctags" VERBATIM )
+ add_custom_target(documentation
+ ${DOXYGEN_EXECUTABLE} ${CMAKE_CURRENT_BINARY_DIR}/libccnx_api_portal-stage2.doxygen
+ WORKING_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}
+ COMMENT "Generating Documentation" VERBATIM )
+ add_custom_target(clobber-docs
+ COMMAND /bin/rm -rf ${CMAKE_CURRENT_BINARY_DIR}/libccnx_api_portal-documentation
+ WORKING_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}
+ COMMENT "Removing Documentation" VERBATIM )
+endif(DOXYGEN_FOUND)