aboutsummaryrefslogtreecommitdiffstats
path: root/libccnx-transport-rta/ccnx/transport/transport_rta/core/test/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'libccnx-transport-rta/ccnx/transport/transport_rta/core/test/CMakeLists.txt')
-rw-r--r--libccnx-transport-rta/ccnx/transport/transport_rta/core/test/CMakeLists.txt23
1 files changed, 23 insertions, 0 deletions
diff --git a/libccnx-transport-rta/ccnx/transport/transport_rta/core/test/CMakeLists.txt b/libccnx-transport-rta/ccnx/transport/transport_rta/core/test/CMakeLists.txt
new file mode 100644
index 00000000..b57c2afd
--- /dev/null
+++ b/libccnx-transport-rta/ccnx/transport/transport_rta/core/test/CMakeLists.txt
@@ -0,0 +1,23 @@
+# Enable gcov output for the tests
+add_definitions(--coverage)
+set(CMAKE_EXE_LINKER_FLAGS ${CMAKE_EXE_LINKER_FLAGS} " --coverage")
+
+set(TestsExpectedToPass
+ test_rta_ConnectionTable
+ test_rta_Framework
+ test_rta_Framework_Commands
+ test_rta_Component
+ test_rta_Connection
+ test_rta_Framework_NonThreaded
+ test_rta_Framework_Services
+ test_rta_Framework_Threaded
+ test_rta_Logger
+ test_rta_ProtocolStack
+ test_rta_ComponentStats
+)
+
+
+foreach(test ${TestsExpectedToPass})
+ AddTest(${test})
+endforeach()
+