aboutsummaryrefslogtreecommitdiffstats
path: root/libparc/parc/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'libparc/parc/CMakeLists.txt')
-rw-r--r--libparc/parc/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/libparc/parc/CMakeLists.txt b/libparc/parc/CMakeLists.txt
index df582a35..62c81b6e 100644
--- a/libparc/parc/CMakeLists.txt
+++ b/libparc/parc/CMakeLists.txt
@@ -392,7 +392,7 @@ if("${CMAKE_CXX_COMPILER_ID}" STREQUAL "AppleClang" OR COMPILE_FOR_IOS)
set(CMAKE_SHARED_LIBRARY_CREATE_C_FLAGS "${CMAKE_SHARED_LIBRARY_CREATE_C_FLAGS} -undefined dynamic_lookup")
message( "-- Set \"-undefined dynamic_lookup\" for shared libraries")
endif()
-if(COMPILE_FOR_IOS OR ANDROID_API)
+if(COMPILE_FOR_IOS OR ${CMAKE_SYSTEM_NAME} STREQUAL "Android")
add_library(parc STATIC ${LIBPARC_SOURCE_FILES} ${LIBEVENT_LIBRARIES} ${OPENSSL_LIBRARIES})
target_link_libraries(parc ${LIBEVENT_LIBRARIES})
target_link_libraries(parc ${OPENSSL_LIBRARIES})