aboutsummaryrefslogtreecommitdiffstats
path: root/metis/ccnx/forwarder/metis/processor/test/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'metis/ccnx/forwarder/metis/processor/test/CMakeLists.txt')
-rw-r--r--metis/ccnx/forwarder/metis/processor/test/CMakeLists.txt21
1 files changed, 21 insertions, 0 deletions
diff --git a/metis/ccnx/forwarder/metis/processor/test/CMakeLists.txt b/metis/ccnx/forwarder/metis/processor/test/CMakeLists.txt
new file mode 100644
index 00000000..aae53353
--- /dev/null
+++ b/metis/ccnx/forwarder/metis/processor/test/CMakeLists.txt
@@ -0,0 +1,21 @@
+# Enable gcov output for the tests
+add_definitions(--coverage)
+set(CMAKE_EXE_LINKER_FLAGS ${CMAKE_EXE_LINKER_FLAGS} " --coverage")
+
+set(TestsExpectedToPass
+ test_metis_FIB
+ test_metis_FibEntryList
+ test_metis_HashTableFunction
+ test_metis_FibEntry
+ test_metis_MatchingRulesTable
+ test_metis_MessageProcessor
+ test_metis_PIT
+ test_metis_PitEntry
+ test_metis_StandardPIT
+)
+
+
+foreach(test ${TestsExpectedToPass})
+ AddTest(${test})
+endforeach()
+