summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristian Ehrhardt <christian.ehrhardt@canonical.com>2016-09-29 16:40:50 +0200
committerChristian Ehrhardt <christian.ehrhardt@canonical.com>2016-09-29 16:40:50 +0200
commit341d9ed5cf2aa5da89397e62c900e2d325b8d634 (patch)
treed6deedab700a652680bbacce9a4f2d4584e9b9a7
parent91333d2593faebed02728bb8fb9717c808407958 (diff)
add empty RTE_EAL_PMD_PATH dir to librte_eal
If EAL is initialized and the path isn't existing at all (=no PMDs at all are installed) the initialization fails with: EAL: /usr/lib/x86_64-linux-gnu/dpdk-pmds/: cannot open shared object file: No such file or directory So since we support RTE_EAL_PMD_PATH now but can never guarantee that there always will be a PMD it becomes a requirement of librte_eal to have at least an empty path. An empty path is fine and will not load anything, but avoid the initializaiton error. Change-Id: I2725169c67c190f8ed8b608fc5ae508ae66eab1c Signed-off-by: Christian Ehrhardt <christian.ehrhardt@canonical.com>
-rwxr-xr-xdebian/rules3
1 files changed, 3 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index e4684928..ccd61406 100755
--- a/debian/rules
+++ b/debian/rules
@@ -217,6 +217,9 @@ override_dh_auto_install-arch:
echo "PMD: linking $${LIBF} into RTE_EAL_PMD_PATH at $${LIBD}/dpdk-pmds/"; \
ln -s --relative --target-directory=$${LIBD}/dpdk-pmds/ $${LIBD}/$${LIBF}; \
fi; \
+ if [ "$${LIBF#librte_eal}x" != "$${LIBF}x" ]; then \
+ mkdir -p $${LIBD}/dpdk-pmds; \
+ fi; \
done
# pkg-config
mkdir -p debian/libdpdk-dev/$(LIBDIR)/pkgconfig