aboutsummaryrefslogtreecommitdiffstats
path: root/debian/patches/mk-sort-list-of-files-in-examples.dox.patch
diff options
context:
space:
mode:
authorLuca Boccassi <luca.boccassi@gmail.com>2017-06-22 15:40:17 +0100
committerLuca Boccassi <luca.boccassi@gmail.com>2017-06-22 15:40:17 +0100
commit0a1d33da0b68b237e55ec0216133f0951aa16d91 (patch)
tree8f7df40ff46e4748ffa185e0ea2e222e09ec3ebd /debian/patches/mk-sort-list-of-files-in-examples.dox.patch
parent91bd1b4a799800966789e4c28de7b34f3bd42499 (diff)
Backport patches to fix reproducibility issues
These patches make the documentation and linker script generation fully reproducible. Change-Id: Iec5a3578d54f810edd0a0bf1551cacf394e4af32 Signed-off-by: Luca Boccassi <luca.boccassi@gmail.com>
Diffstat (limited to 'debian/patches/mk-sort-list-of-files-in-examples.dox.patch')
-rw-r--r--debian/patches/mk-sort-list-of-files-in-examples.dox.patch31
1 files changed, 31 insertions, 0 deletions
diff --git a/debian/patches/mk-sort-list-of-files-in-examples.dox.patch b/debian/patches/mk-sort-list-of-files-in-examples.dox.patch
new file mode 100644
index 00000000..afe1b199
--- /dev/null
+++ b/debian/patches/mk-sort-list-of-files-in-examples.dox.patch
@@ -0,0 +1,31 @@
+Description: mk: sort list of files in examples.dox
+
+The result of find might not be stable depending on external
+conditions.
+Pipe it through LC_ALL=C sort to ensure reproducible results when
+generating examples.dox.
+
+Origin: http://dpdk.org/dev/patchwork/patch/25634/
+Forwarded: yes
+Author: Luca Boccassi <luca.boccassi@gmail.com>
+Last-Update: 2017-06-22
+---
+ mk/rte.sdkdoc.mk | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/mk/rte.sdkdoc.mk b/mk/rte.sdkdoc.mk
+index c0eaa3502..de31b78cf 100644
+--- a/mk/rte.sdkdoc.mk
++++ b/mk/rte.sdkdoc.mk
+@@ -93,7 +93,7 @@ $(API_EXAMPLES): api-html-clean
+ $(Q)mkdir -p $(@D)
+ @printf '/**\n' > $(API_EXAMPLES)
+ @printf '@page examples DPDK Example Programs\n\n' >> $(API_EXAMPLES)
+- @find examples -type f -name '*.c' -printf '@example %p\n' >> $(API_EXAMPLES)
++ @find examples -type f -name '*.c' -printf '@example %p\n' | LC_ALL=C sort >> $(API_EXAMPLES)
+ @printf '*/\n' >> $(API_EXAMPLES)
+
+ guides-pdf-clean: guides-pdf-img-clean
+--
+2.11.0
+