aboutsummaryrefslogtreecommitdiffstats
path: root/debian/patches/mk-sort-list-of-shared-objects-in-linker-script.patch
diff options
context:
space:
mode:
authorLuca Boccassi <luca.boccassi@gmail.com>2017-06-22 15:40:17 +0100
committerLuca Boccassi <luca.boccassi@gmail.com>2017-06-22 15:40:17 +0100
commit0a1d33da0b68b237e55ec0216133f0951aa16d91 (patch)
tree8f7df40ff46e4748ffa185e0ea2e222e09ec3ebd /debian/patches/mk-sort-list-of-shared-objects-in-linker-script.patch
parent91bd1b4a799800966789e4c28de7b34f3bd42499 (diff)
Backport patches to fix reproducibility issues
These patches make the documentation and linker script generation fully reproducible. Change-Id: Iec5a3578d54f810edd0a0bf1551cacf394e4af32 Signed-off-by: Luca Boccassi <luca.boccassi@gmail.com>
Diffstat (limited to 'debian/patches/mk-sort-list-of-shared-objects-in-linker-script.patch')
-rw-r--r--debian/patches/mk-sort-list-of-shared-objects-in-linker-script.patch32
1 files changed, 32 insertions, 0 deletions
diff --git a/debian/patches/mk-sort-list-of-shared-objects-in-linker-script.patch b/debian/patches/mk-sort-list-of-shared-objects-in-linker-script.patch
new file mode 100644
index 00000000..52e6b5a5
--- /dev/null
+++ b/debian/patches/mk-sort-list-of-shared-objects-in-linker-script.patch
@@ -0,0 +1,32 @@
+Description: mk: sort list of shared objects in linker script
+
+The output of wildcard might not be stable and depend on the
+filesystem and other factors.
+This means the content libdpdk.so linker script might change between
+builds from the same sources.
+Run the list through sort to ensure reproducibility.
+
+Origin: http://dpdk.org/dev/patchwork/patch/25633/
+Forwarded: yes
+Author: Luca Boccassi <luca.boccassi@gmail.com>
+Last-Update: 2017-06-22
+---
+ mk/rte.combinedlib.mk | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/mk/rte.combinedlib.mk b/mk/rte.combinedlib.mk
+index 449358b33..2ab7ee8a1 100644
+--- a/mk/rte.combinedlib.mk
++++ b/mk/rte.combinedlib.mk
+@@ -42,7 +42,7 @@ endif
+ RTE_LIBNAME := dpdk
+ COMBINEDLIB := lib$(RTE_LIBNAME)$(EXT)
+
+-LIBS := $(filter-out $(COMBINEDLIB), $(notdir $(wildcard $(RTE_OUTPUT)/lib/*$(EXT))))
++LIBS := $(filter-out $(COMBINEDLIB), $(sort $(notdir $(wildcard $(RTE_OUTPUT)/lib/*$(EXT)))))
+
+ all: FORCE
+ $(Q)echo "GROUP ( $(LIBS) )" > $(RTE_OUTPUT)/lib/$(COMBINEDLIB)
+--
+2.11.0
+