aboutsummaryrefslogtreecommitdiffstats
path: root/debian/patches/mk-sort-source-files-before-passing-them-to-the-comp.patch
diff options
context:
space:
mode:
authorLuca Boccassi <luca.boccassi@gmail.com>2017-06-24 15:13:55 +0100
committerLuca Boccassi <luca.boccassi@gmail.com>2017-06-24 15:25:10 +0100
commit146be0ebc2d0e889d7123bdd7ef277216b9ded8e (patch)
tree28c0ea80138af0c8c0b103273c1d22068a62edfb /debian/patches/mk-sort-source-files-before-passing-them-to-the-comp.patch
parent1bbe7a6805988f1f328ddead4d13ec4731e31691 (diff)
Add new patches to make build fully reproducible
Change-Id: Ic9012604e9bf5e9da22f9eb7a96b6ecb3bfb2ff1 Signed-off-by: Luca Boccassi <luca.boccassi@gmail.com>
Diffstat (limited to 'debian/patches/mk-sort-source-files-before-passing-them-to-the-comp.patch')
-rw-r--r--debian/patches/mk-sort-source-files-before-passing-them-to-the-comp.patch127
1 files changed, 127 insertions, 0 deletions
diff --git a/debian/patches/mk-sort-source-files-before-passing-them-to-the-comp.patch b/debian/patches/mk-sort-source-files-before-passing-them-to-the-comp.patch
new file mode 100644
index 00000000..0fb0bad8
--- /dev/null
+++ b/debian/patches/mk-sort-source-files-before-passing-them-to-the-comp.patch
@@ -0,0 +1,127 @@
+Description: mk: sort source files before passing them to the compiler
+
+In order to achieve reproducible builds, always use the same
+order when listing files for compilation.
+
+Origin: http://dpdk.org/dev/patchwork/patch/25678/
+Forwarded: yes
+Author: Luca Boccassi <luca.boccassi@gmail.com>
+Last-Update: 2017-06-24
+---
+ drivers/net/cxgbe/Makefile | 2 +-
+ drivers/net/e1000/Makefile | 2 +-
+ drivers/net/fm10k/Makefile | 2 +-
+ drivers/net/i40e/Makefile | 2 +-
+ drivers/net/ixgbe/Makefile | 2 +-
+ drivers/net/qede/Makefile | 2 +-
+ drivers/net/sfc/Makefile | 2 +-
+ drivers/net/thunderx/Makefile | 2 +-
+ 8 files changed, 8 insertions(+), 8 deletions(-)
+
+diff --git a/drivers/net/cxgbe/Makefile b/drivers/net/cxgbe/Makefile
+index 7cef6279c..b4666b5af 100644
+--- a/drivers/net/cxgbe/Makefile
++++ b/drivers/net/cxgbe/Makefile
+@@ -67,7 +67,7 @@ endif
+ # Add extra flags for base driver files (also known as shared code)
+ # to disable warnings in them
+ #
+-BASE_DRIVER_OBJS=$(patsubst %.c,%.o,$(notdir $(wildcard $(SRCDIR)/base/*.c)))
++BASE_DRIVER_OBJS=$(sort $(patsubst %.c,%.o,$(notdir $(wildcard $(SRCDIR)/base/*.c))))
+ $(foreach obj, $(BASE_DRIVER_OBJS), $(eval CFLAGS_$(obj)+=$(CFLAGS_BASE_DRIVER)))
+
+ VPATH += $(SRCDIR)/base
+diff --git a/drivers/net/e1000/Makefile b/drivers/net/e1000/Makefile
+index ffdf36d37..59d96bca1 100644
+--- a/drivers/net/e1000/Makefile
++++ b/drivers/net/e1000/Makefile
+@@ -68,7 +68,7 @@ endif
+ # Add extra flags for base driver files (also known as shared code)
+ # to disable warnings in them
+ #
+-BASE_DRIVER_OBJS=$(patsubst %.c,%.o,$(notdir $(wildcard $(SRCDIR)/base/*.c)))
++BASE_DRIVER_OBJS=$(sort $(patsubst %.c,%.o,$(notdir $(wildcard $(SRCDIR)/base/*.c))))
+ $(foreach obj, $(BASE_DRIVER_OBJS), $(eval CFLAGS_$(obj)+=$(CFLAGS_BASE_DRIVER)))
+
+ VPATH += $(SRCDIR)/base
+diff --git a/drivers/net/fm10k/Makefile b/drivers/net/fm10k/Makefile
+index e0024f052..0bc124eb1 100644
+--- a/drivers/net/fm10k/Makefile
++++ b/drivers/net/fm10k/Makefile
+@@ -80,7 +80,7 @@ endif
+ #
+ # Add extra flags for base driver source files to disable warnings in them
+ #
+-BASE_DRIVER_OBJS=$(patsubst %.c,%.o,$(notdir $(wildcard $(SRCDIR)/base/*.c)))
++BASE_DRIVER_OBJS=$(sort $(patsubst %.c,%.o,$(notdir $(wildcard $(SRCDIR)/base/*.c))))
+ $(foreach obj, $(BASE_DRIVER_OBJS), $(eval CFLAGS_$(obj)+=$(CFLAGS_BASE_DRIVER)))
+
+ VPATH += $(SRCDIR)/base
+diff --git a/drivers/net/i40e/Makefile b/drivers/net/i40e/Makefile
+index 56f210d6d..06eedc592 100644
+--- a/drivers/net/i40e/Makefile
++++ b/drivers/net/i40e/Makefile
+@@ -78,7 +78,7 @@ endif
+
+ CFLAGS_i40e_lan_hmc.o += -Wno-error
+ endif
+-OBJS_BASE_DRIVER=$(patsubst %.c,%.o,$(notdir $(wildcard $(SRCDIR)/base/*.c)))
++OBJS_BASE_DRIVER=$(sort $(patsubst %.c,%.o,$(notdir $(wildcard $(SRCDIR)/base/*.c))))
+ $(foreach obj, $(OBJS_BASE_DRIVER), $(eval CFLAGS_$(obj)+=$(CFLAGS_BASE_DRIVER)))
+
+ VPATH += $(SRCDIR)/base
+diff --git a/drivers/net/ixgbe/Makefile b/drivers/net/ixgbe/Makefile
+index 6a651b923..f5c370ce5 100644
+--- a/drivers/net/ixgbe/Makefile
++++ b/drivers/net/ixgbe/Makefile
+@@ -87,7 +87,7 @@ endif
+ # Add extra flags for base driver files (also known as shared code)
+ # to disable warnings in them
+ #
+-BASE_DRIVER_OBJS=$(patsubst %.c,%.o,$(notdir $(wildcard $(SRCDIR)/base/*.c)))
++BASE_DRIVER_OBJS=$(sort $(patsubst %.c,%.o,$(notdir $(wildcard $(SRCDIR)/base/*.c))))
+ $(foreach obj, $(BASE_DRIVER_OBJS), $(eval CFLAGS_$(obj)+=$(CFLAGS_BASE_DRIVER)))
+
+ VPATH += $(SRCDIR)/base
+diff --git a/drivers/net/qede/Makefile b/drivers/net/qede/Makefile
+index f03441d9a..83ff95474 100644
+--- a/drivers/net/qede/Makefile
++++ b/drivers/net/qede/Makefile
+@@ -78,7 +78,7 @@ endif
+ # to disable warnings in them
+ #
+ #
+-BASE_DRIVER_OBJS=$(patsubst %.c,%.o,$(notdir $(wildcard $(SRCDIR)/base/*.c)))
++BASE_DRIVER_OBJS=$(sort $(patsubst %.c,%.o,$(notdir $(wildcard $(SRCDIR)/base/*.c))))
+ $(foreach obj, $(BASE_DRIVER_OBJS), $(eval CFLAGS_$(obj)+=$(CFLAGS_BASE_DRIVER)))
+
+ VPATH += $(SRCDIR)/base
+diff --git a/drivers/net/sfc/Makefile b/drivers/net/sfc/Makefile
+index 57aa963ba..8cfd14d45 100644
+--- a/drivers/net/sfc/Makefile
++++ b/drivers/net/sfc/Makefile
+@@ -71,7 +71,7 @@ endif
+ # List of base driver object files for which
+ # special CFLAGS above should be applied
+ #
+-BASE_DRIVER_OBJS=$(patsubst %.c,%.o,$(notdir $(wildcard $(SRCDIR)/base/*.c)))
++BASE_DRIVER_OBJS=$(sort $(patsubst %.c,%.o,$(notdir $(wildcard $(SRCDIR)/base/*.c))))
+ $(foreach obj, $(BASE_DRIVER_OBJS), \
+ $(eval CFLAGS_$(obj)+=$(CFLAGS_BASE_DRIVER)))
+
+diff --git a/drivers/net/thunderx/Makefile b/drivers/net/thunderx/Makefile
+index 706250b8b..ac384a624 100644
+--- a/drivers/net/thunderx/Makefile
++++ b/drivers/net/thunderx/Makefile
+@@ -45,7 +45,7 @@ EXPORT_MAP := rte_pmd_thunderx_nicvf_version.map
+
+ LIBABIVER := 1
+
+-OBJS_BASE_DRIVER=$(patsubst %.c,%.o,$(notdir $(wildcard $(SRCDIR)/base/*.c)))
++OBJS_BASE_DRIVER=$(sort $(patsubst %.c,%.o,$(notdir $(wildcard $(SRCDIR)/base/*.c))))
+ $(foreach obj, $(OBJS_BASE_DRIVER), $(eval CFLAGS_$(obj)+=$(CFLAGS_BASE_DRIVER)))
+
+ VPATH += $(SRCDIR)/base
+--
+2.11.0
+