aboutsummaryrefslogtreecommitdiffstats
path: root/debian/patches/nicvf-0004-net-thunderx-sync-mailbox-definitions-with-Linux-PF-.patch
diff options
context:
space:
mode:
authorLuca Boccassi <luca.boccassi@gmail.com>2017-06-19 13:21:21 +0100
committerLuca Boccassi <luca.boccassi@gmail.com>2017-06-19 13:21:46 +0100
commit9bd59f949df83594e434ea6b83b3bff841e6fd31 (patch)
treefaa977d7b7060b1058e338b33dda3f537fba3c21 /debian/patches/nicvf-0004-net-thunderx-sync-mailbox-definitions-with-Linux-PF-.patch
parent1f784092de6f79612c6b1a4a4208f3abb03e7084 (diff)
parente17e83e3a136be1a66eb1b580a4f049912b81657 (diff)
Merge branch '16.11.x' into 17.05.x
Conflicts: app/test-pmd/parameters.c app/test-pmd/testpmd.c debian/changelog debian/control debian/patches/fix-vhost-user-socket-permission.patch debian/rules doc/guides/cryptodevs/qat.rst doc/guides/nics/thunderx.rst doc/guides/rel_notes/release_16_11.rst drivers/net/i40e/i40e_rxtx_vec_neon.c drivers/net/ixgbe/ixgbe_rxtx.c drivers/net/mlx5/mlx5_rxtx.c drivers/net/nfp/nfp_net.c drivers/net/qede/qede_ethdev.c drivers/net/thunderx/nicvf_struct.h drivers/net/virtio/virtio_ethdev.c drivers/net/virtio/virtio_pci.c drivers/net/virtio/virtio_pci.h drivers/net/virtio/virtio_user/virtio_user_dev.c drivers/net/virtio/virtio_user/virtio_user_dev.h drivers/net/virtio/virtio_user_ethdev.c examples/dpdk_qat/main.c examples/performance-thread/l3fwd-thread/main.c examples/quota_watermark/qw/init.c lib/librte_eal/bsdapp/eal/eal_pci.c lib/librte_eal/common/include/rte_version.h lib/librte_vhost/socket.c lib/librte_vhost/vhost.c lib/librte_vhost/vhost.h pkg/dpdk.spec test/test/test_mempool.c Change-Id: I04809b1bcf4ecee4c171c5acb60a8a8aac8cc4a8 Signed-off-by: Luca Boccassi <luca.boccassi@gmail.com>
Diffstat (limited to 'debian/patches/nicvf-0004-net-thunderx-sync-mailbox-definitions-with-Linux-PF-.patch')
-rw-r--r--debian/patches/nicvf-0004-net-thunderx-sync-mailbox-definitions-with-Linux-PF-.patch80
1 files changed, 80 insertions, 0 deletions
diff --git a/debian/patches/nicvf-0004-net-thunderx-sync-mailbox-definitions-with-Linux-PF-.patch b/debian/patches/nicvf-0004-net-thunderx-sync-mailbox-definitions-with-Linux-PF-.patch
new file mode 100644
index 00000000..2ff3a2db
--- /dev/null
+++ b/debian/patches/nicvf-0004-net-thunderx-sync-mailbox-definitions-with-Linux-PF-.patch
@@ -0,0 +1,80 @@
+From 2d5a4b62ff2d7b79ca937a5c88654deecf4aa986 Mon Sep 17 00:00:00 2001
+From: Jerin Jacob <jerin.jacob@caviumnetworks.com>
+Date: Mon, 20 Mar 2017 19:40:40 +0530
+Subject: [PATCH] net/thunderx: sync mailbox definitions with Linux PF driver
+
+- bgx_link_status mbox definition was changed in Linux
+commit 1cc702591bae ("net: thunderx: Add ethtool support")
+- NIC_MBOX_MSG_RES_BIT related changes were never part of Linux PF driver
+
+Signed-off-by: Jerin Jacob <jerin.jacob@caviumnetworks.com>
+---
+ drivers/net/thunderx/base/nicvf_mbox.c | 7 ++-----
+ drivers/net/thunderx/base/nicvf_mbox.h | 11 +++--------
+ 2 files changed, 5 insertions(+), 13 deletions(-)
+
+Origin: http://dpdk.org/browse/dpdk/commit/?id=2d5a4b62ff2d7b79ca937a5c88654deecf4aa986
+Original-Author: Jerin Jacob <jerin.jacob@caviumnetworks.com>
+Bug-Ubuntu: https://bugs.launchpad.net/ubuntu/+source/dpdk/+bug/1691659
+Author: Christian Ehrhardt <christian.ehrhardt@canonical.com>
+Last-Update: 2017-05-18
+
+--- a/drivers/net/thunderx/base/nicvf_mbox.c
++++ b/drivers/net/thunderx/base/nicvf_mbox.c
+@@ -62,9 +62,6 @@
+ [NIC_MBOX_MSG_RESET_STAT_COUNTER] = "NIC_MBOX_MSG_RESET_STAT_COUNTER",
+ [NIC_MBOX_MSG_CFG_DONE] = "NIC_MBOX_MSG_CFG_DONE",
+ [NIC_MBOX_MSG_SHUTDOWN] = "NIC_MBOX_MSG_SHUTDOWN",
+- [NIC_MBOX_MSG_RES_BIT] = "NIC_MBOX_MSG_RES_BIT",
+- [NIC_MBOX_MSG_RSS_SIZE_RES_BIT] = "NIC_MBOX_MSG_RSS_SIZE",
+- [NIC_MBOX_MSG_ALLOC_SQS_RES_BIT] = "NIC_MBOX_MSG_ALLOC_SQS",
+ };
+
+ static inline const char * __attribute__((unused))
+@@ -176,7 +173,7 @@
+ case NIC_MBOX_MSG_NACK:
+ nic->pf_nacked = true;
+ break;
+- case NIC_MBOX_MSG_RSS_SIZE_RES_BIT:
++ case NIC_MBOX_MSG_RSS_SIZE:
+ nic->rss_info.rss_size = mbx.rss_size.ind_tbl_size;
+ nic->pf_acked = true;
+ break;
+@@ -186,7 +183,7 @@
+ nic->speed = mbx.link_status.speed;
+ nic->pf_acked = true;
+ break;
+- case NIC_MBOX_MSG_ALLOC_SQS_RES_BIT:
++ case NIC_MBOX_MSG_ALLOC_SQS:
+ assert_primary(nic);
+ if (mbx.sqs_alloc.qs_count != nic->sqs_count) {
+ nicvf_log_error("Received %" PRIu8 "/%" PRIu8
+--- a/drivers/net/thunderx/base/nicvf_mbox.h
++++ b/drivers/net/thunderx/base/nicvf_mbox.h
+@@ -68,16 +68,10 @@
+ #define NIC_MBOX_MSG_ALLOC_SQS 0x12 /* Allocate secondary Qset */
+ #define NIC_MBOX_MSG_LOOPBACK 0x16 /* Set interface in loopback */
+ #define NIC_MBOX_MSG_RESET_STAT_COUNTER 0x17 /* Reset statistics counters */
+-#define NIC_MBOX_MSG_CFG_DONE 0x7E /* VF configuration done */
+-#define NIC_MBOX_MSG_SHUTDOWN 0x7F /* VF is being shutdown */
+-#define NIC_MBOX_MSG_RES_BIT 0x80 /* Reset bit from PF */
++#define NIC_MBOX_MSG_CFG_DONE 0xF0 /* VF configuration done */
++#define NIC_MBOX_MSG_SHUTDOWN 0xF1 /* VF is being shutdown */
+ #define NIC_MBOX_MSG_MAX 0x100 /* Maximum number of messages */
+
+-#define NIC_MBOX_MSG_RSS_SIZE_RES_BIT \
+- (NIC_MBOX_MSG_RSS_SIZE | NIC_MBOX_MSG_RES_BIT)
+-#define NIC_MBOX_MSG_ALLOC_SQS_RES_BIT \
+- (NIC_MBOX_MSG_ALLOC_SQS | NIC_MBOX_MSG_RES_BIT)
+-
+ /* Get vNIC VF configuration */
+ struct nic_cfg_msg {
+ uint8_t msg;
+@@ -157,6 +151,7 @@
+ /* Physical interface link status */
+ struct bgx_link_status {
+ uint8_t msg;
++ uint8_t mac_type;
+ uint8_t link_up;
+ uint8_t duplex;
+ uint32_t speed;