aboutsummaryrefslogtreecommitdiffstats
path: root/debian/patches/ubuntu-backport-40-linking-fixes-stage-4-4.patch
diff options
context:
space:
mode:
authorChristian Ehrhardt <christian.ehrhardt@canonical.com>2016-06-15 20:29:06 +0200
committerChristian Ehrhardt <christian.ehrhardt@canonical.com>2016-06-15 20:37:12 +0200
commit199e427d5dea3051eec1726eb9c857aa3d5fdde2 (patch)
tree5477b3bd4868676a210bbd3ef67a469d34814e61 /debian/patches/ubuntu-backport-40-linking-fixes-stage-4-4.patch
parentb5cdd645c9fc62341d55aebbfc93a1b648415512 (diff)
Merge Ubuntu DPDK packaging as of 15th June 2016
As discussed this shall be our initial baseline. If history is needed for any sort of debugging or analysis it can be found at https://code.launchpad.net/~ubuntu-server/dpdk/+git/dpdk Change-Id: Ie95c7effbbea34d723df14f6451c1f782000cbc1 Signed-off-by: Christian Ehrhardt <christian.ehrhardt@canonical.com>
Diffstat (limited to 'debian/patches/ubuntu-backport-40-linking-fixes-stage-4-4.patch')
-rw-r--r--debian/patches/ubuntu-backport-40-linking-fixes-stage-4-4.patch149
1 files changed, 149 insertions, 0 deletions
diff --git a/debian/patches/ubuntu-backport-40-linking-fixes-stage-4-4.patch b/debian/patches/ubuntu-backport-40-linking-fixes-stage-4-4.patch
new file mode 100644
index 00000000..188ee2bd
--- /dev/null
+++ b/debian/patches/ubuntu-backport-40-linking-fixes-stage-4-4.patch
@@ -0,0 +1,149 @@
+Description: backport of dpdk 16.07 fix for library underlinking - stage 4/4
+
+This is a merge of related upstream fixes:
+- 473b718f mk: fix vhost dependency to pthread
+- 6cbf4f75 mk: fix missing internal dependencies
+
+Forwarded: yes (in DPDK 16.07)
+Author: Christian Ehrhardt <christian.ehrhardt@canonical.com>
+Last-Update: 2016-06-14
+
+Index: dpdk/drivers/net/vhost/Makefile
+===================================================================
+--- dpdk.orig/drivers/net/vhost/Makefile
++++ dpdk/drivers/net/vhost/Makefile
+@@ -36,6 +36,8 @@ include $(RTE_SDK)/mk/rte.vars.mk
+ #
+ LIB = librte_pmd_vhost.a
+
++LDLIBS += -lpthread
++
+ CFLAGS += -O3
+ CFLAGS += $(WERROR_FLAGS)
+
+@@ -54,6 +56,7 @@ SRCS-$(CONFIG_RTE_LIBRTE_PMD_VHOST) += r
+ SYMLINK-y-include += rte_eth_vhost.h
+
+ # this lib depends upon:
++DEPDIRS-$(CONFIG_RTE_LIBRTE_PMD_VHOST) += lib/librte_eal
+ DEPDIRS-$(CONFIG_RTE_LIBRTE_PMD_VHOST) += lib/librte_mbuf
+ DEPDIRS-$(CONFIG_RTE_LIBRTE_PMD_VHOST) += lib/librte_ether
+ DEPDIRS-$(CONFIG_RTE_LIBRTE_PMD_VHOST) += lib/librte_kvargs
+Index: dpdk/drivers/crypto/null/Makefile
+===================================================================
+--- dpdk.orig/drivers/crypto/null/Makefile
++++ dpdk/drivers/crypto/null/Makefile
+@@ -55,5 +55,7 @@ SYMLINK-y-include +=
+ DEPDIRS-$(CONFIG_RTE_LIBRTE_PMD_NULL_CRYPTO) += lib/librte_eal
+ DEPDIRS-$(CONFIG_RTE_LIBRTE_PMD_NULL_CRYPTO) += lib/librte_mbuf
+ DEPDIRS-$(CONFIG_RTE_LIBRTE_PMD_NULL_CRYPTO) += lib/librte_cryptodev
++DEPDIRS-$(CONFIG_RTE_LIBRTE_PMD_NULL_CRYPTO) += lib/librte_ring
++DEPDIRS-$(CONFIG_RTE_LIBRTE_PMD_NULL_CRYPTO) += lib/librte_kvargs
+
+ include $(RTE_SDK)/mk/rte.lib.mk
+Index: dpdk/drivers/net/af_packet/Makefile
+===================================================================
+--- dpdk.orig/drivers/net/af_packet/Makefile
++++ dpdk/drivers/net/af_packet/Makefile
+@@ -51,6 +51,7 @@ CFLAGS += $(WERROR_FLAGS)
+ SRCS-$(CONFIG_RTE_LIBRTE_PMD_AF_PACKET) += rte_eth_af_packet.c
+
+ # this lib depends upon:
++DEPDIRS-$(CONFIG_RTE_LIBRTE_PMD_AF_PACKET) += lib/librte_eal
+ DEPDIRS-$(CONFIG_RTE_LIBRTE_PMD_AF_PACKET) += lib/librte_mbuf
+ DEPDIRS-$(CONFIG_RTE_LIBRTE_PMD_AF_PACKET) += lib/librte_ether
+ DEPDIRS-$(CONFIG_RTE_LIBRTE_PMD_AF_PACKET) += lib/librte_kvargs
+Index: dpdk/drivers/net/bonding/Makefile
+===================================================================
+--- dpdk.orig/drivers/net/bonding/Makefile
++++ dpdk/drivers/net/bonding/Makefile
+@@ -64,5 +64,7 @@ DEPDIRS-$(CONFIG_RTE_LIBRTE_PMD_BOND) +=
+ DEPDIRS-$(CONFIG_RTE_LIBRTE_PMD_BOND) += lib/librte_eal
+ DEPDIRS-$(CONFIG_RTE_LIBRTE_PMD_BOND) += lib/librte_kvargs
+ DEPDIRS-$(CONFIG_RTE_LIBRTE_PMD_BOND) += lib/librte_cmdline
++DEPDIRS-$(CONFIG_RTE_LIBRTE_PMD_BOND) += lib/librte_mempool
++DEPDIRS-$(CONFIG_RTE_LIBRTE_PMD_BOND) += lib/librte_ring
+
+ include $(RTE_SDK)/mk/rte.lib.mk
+Index: dpdk/drivers/net/fm10k/Makefile
+===================================================================
+--- dpdk.orig/drivers/net/fm10k/Makefile
++++ dpdk/drivers/net/fm10k/Makefile
+@@ -99,5 +99,6 @@ SRCS-$(CONFIG_RTE_LIBRTE_FM10K_INC_VECTO
+ DEPDIRS-$(CONFIG_RTE_LIBRTE_FM10K_PMD) += lib/librte_eal lib/librte_ether
+ DEPDIRS-$(CONFIG_RTE_LIBRTE_FM10K_PMD) += lib/librte_mempool lib/librte_mbuf
+ DEPDIRS-$(CONFIG_RTE_LIBRTE_FM10K_PMD) += lib/librte_net
++DEPDIRS-$(CONFIG_RTE_LIBRTE_FM10K_PMD) += lib/librte_kvargs
+
+ include $(RTE_SDK)/mk/rte.lib.mk
+Index: dpdk/drivers/net/null/Makefile
+===================================================================
+--- dpdk.orig/drivers/net/null/Makefile
++++ dpdk/drivers/net/null/Makefile
+@@ -54,6 +54,7 @@ SRCS-$(CONFIG_RTE_LIBRTE_PMD_NULL) += rt
+ SYMLINK-y-include += rte_eth_null.h
+
+ # this lib depends upon:
++DEPDIRS-$(CONFIG_RTE_LIBRTE_PMD_NULL) += lib/librte_eal
+ DEPDIRS-$(CONFIG_RTE_LIBRTE_PMD_NULL) += lib/librte_mbuf
+ DEPDIRS-$(CONFIG_RTE_LIBRTE_PMD_NULL) += lib/librte_ether
+ DEPDIRS-$(CONFIG_RTE_LIBRTE_PMD_NULL) += lib/librte_kvargs
+Index: dpdk/drivers/net/pcap/Makefile
+===================================================================
+--- dpdk.orig/drivers/net/pcap/Makefile
++++ dpdk/drivers/net/pcap/Makefile
+@@ -56,6 +56,7 @@ SRCS-$(CONFIG_RTE_LIBRTE_PMD_PCAP) += rt
+ SYMLINK-y-include +=
+
+ # this lib depends upon:
++DEPDIRS-$(CONFIG_RTE_LIBRTE_PMD_PCAP) += lib/librte_eal
+ DEPDIRS-$(CONFIG_RTE_LIBRTE_PMD_PCAP) += lib/librte_mbuf
+ DEPDIRS-$(CONFIG_RTE_LIBRTE_PMD_PCAP) += lib/librte_ether
+ DEPDIRS-$(CONFIG_RTE_LIBRTE_PMD_PCAP) += lib/librte_kvargs
+Index: dpdk/lib/librte_ip_frag/Makefile
+===================================================================
+--- dpdk.orig/lib/librte_ip_frag/Makefile
++++ dpdk/lib/librte_ip_frag/Makefile
+@@ -54,6 +54,7 @@ SYMLINK-$(CONFIG_RTE_LIBRTE_IP_FRAG)-inc
+
+
+ # this library depends on rte_ether
++DEPDIRS-$(CONFIG_RTE_LIBRTE_IP_FRAG) += lib/librte_eal
+ DEPDIRS-$(CONFIG_RTE_LIBRTE_IP_FRAG) += lib/librte_mempool lib/librte_ether
+
+ include $(RTE_SDK)/mk/rte.lib.mk
+Index: dpdk/lib/librte_pipeline/Makefile
+===================================================================
+--- dpdk.orig/lib/librte_pipeline/Makefile
++++ dpdk/lib/librte_pipeline/Makefile
+@@ -52,6 +52,7 @@ SRCS-$(CONFIG_RTE_LIBRTE_PIPELINE) := rt
+ SYMLINK-$(CONFIG_RTE_LIBRTE_PIPELINE)-include += rte_pipeline.h
+
+ # this lib depends upon:
++DEPDIRS-$(CONFIG_RTE_LIBRTE_PIPELINE) += lib/librte_eal
+ DEPDIRS-$(CONFIG_RTE_LIBRTE_PIPELINE) := lib/librte_table
+ DEPDIRS-$(CONFIG_RTE_LIBRTE_PIPELINE) += lib/librte_port
+
+Index: dpdk/lib/librte_port/Makefile
+===================================================================
+--- dpdk.orig/lib/librte_port/Makefile
++++ dpdk/lib/librte_port/Makefile
+@@ -75,5 +75,6 @@ DEPDIRS-$(CONFIG_RTE_LIBRTE_PORT) += lib
+ DEPDIRS-$(CONFIG_RTE_LIBRTE_PORT) += lib/librte_mempool
+ DEPDIRS-$(CONFIG_RTE_LIBRTE_PORT) += lib/librte_ether
+ DEPDIRS-$(CONFIG_RTE_LIBRTE_PORT) += lib/librte_ip_frag
++DEPDIRS-$(CONFIG_RTE_LIBRTE_PORT) += lib/librte_sched
+
+ include $(RTE_SDK)/mk/rte.lib.mk
+Index: dpdk/lib/librte_sched/Makefile
+===================================================================
+--- dpdk.orig/lib/librte_sched/Makefile
++++ dpdk/lib/librte_sched/Makefile
+@@ -59,6 +59,7 @@ SYMLINK-$(CONFIG_RTE_LIBRTE_SCHED)-inclu
+ SYMLINK-$(CONFIG_RTE_LIBRTE_SCHED)-include += rte_reciprocal.h
+
+ # this lib depends upon:
++DEPDIRS-$(CONFIG_RTE_LIBRTE_SCHED) += lib/librte_eal
+ DEPDIRS-$(CONFIG_RTE_LIBRTE_SCHED) += lib/librte_mempool lib/librte_mbuf
+ DEPDIRS-$(CONFIG_RTE_LIBRTE_SCHED) += lib/librte_net lib/librte_timer
+