aboutsummaryrefslogtreecommitdiffstats
path: root/debian/patches
diff options
context:
space:
mode:
authorLuca Boccassi <luca.boccassi@gmail.com>2016-09-13 20:04:14 +0100
committerLuca Boccassi <luca.boccassi@gmail.com>2016-09-14 11:55:38 +0100
commitf651a5de2fd18c185f65e3321dbebea9590b93c6 (patch)
treec28ad720bcc09ec0bebfe43c10afd9e6be023885 /debian/patches
parent5bc33ee0995cde472a24762742db693283af55f7 (diff)
Build with RTE_DEVEL_BUILD=n to remove rpath
Pass RTE_DEVEL_BUILD=n to make calls to avoid building the test pmds with rpath set to the current path, which is wrong for binaries shipped by distributions. Fixes Lintian Error: E: dpdk: binary-or-shlib-defines-rpath usr/bin/dpdk-pdump /home/lboccass/git/dpdk_deb/debian/build/shared-root/lib Change-Id: I45e6a72beed1769fe35277ec5a2bcf50788254bd Signed-off-by: Luca Boccassi <luca.boccassi@gmail.com>
Diffstat (limited to 'debian/patches')
-rw-r--r--debian/patches/rte-devel-build-env.patch37
-rw-r--r--debian/patches/series1
2 files changed, 38 insertions, 0 deletions
diff --git a/debian/patches/rte-devel-build-env.patch b/debian/patches/rte-devel-build-env.patch
new file mode 100644
index 00000000..a44885b0
--- /dev/null
+++ b/debian/patches/rte-devel-build-env.patch
@@ -0,0 +1,37 @@
+From 5a75a37716f69905af29fbd81aef44625eb69a8b Mon Sep 17 00:00:00 2001
+From: Luca Boccassi <lboccass@brocade.com>
+Date: Wed, 14 Sep 2016 11:47:06 +0100
+Subject: [PATCH] mk: use ?= instead of := for RTE_DEVEL_BUILD
+
+RTE_DEVEL_BUILD is set to := y in mk/rte.vars.mk, which makes it
+impossible to override via an environment variable, and forces users
+to pass it inline in the make call.
+Use ?= instead to have it pick up the environment variable as well.
+
+Cc: <stable@dpdk.org>
+Signed-off-by: Luca Boccassi <lboccass@brocade.com>
+
+Forwarded: yes
+Origin: Upstream, http://dpdk.org/dev/patchwork/patch/15795/
+Author: Luca Boccassi <lboccass@brocade.com>
+Last-Update: 2016-09-14
+---
+ mk/rte.vars.mk | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/mk/rte.vars.mk b/mk/rte.vars.mk
+index 28982a5..21ee0ca 100644
+--- a/mk/rte.vars.mk
++++ b/mk/rte.vars.mk
+@@ -104,7 +104,7 @@ export RTE_TOOLCHAIN
+
+ # developer build automatically enabled in a git tree
+ ifneq ($(wildcard $(RTE_SDK)/.git),)
+-RTE_DEVEL_BUILD := y
++RTE_DEVEL_BUILD ?= y
+ endif
+
+ # SRCDIR is the current source directory
+--
+2.1.4
+
diff --git a/debian/patches/series b/debian/patches/series
index 6e239429..31c7f389 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -5,3 +5,4 @@ dpdk-dev-doc-fix-old-dpdk-nic-bind.py-references.patch
make-load-devel-config-not-to-appear-as-executable.patch
rte-compile-pre-cppflags.patch
fix-power-default-config.patch
+rte-devel-build-env.patch