aboutsummaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorChristian Ehrhardt <christian.ehrhardt@canonical.com>2018-11-15 12:31:48 +0100
committerChristian Ehrhardt <christian.ehrhardt@canonical.com>2018-11-15 12:31:48 +0100
commit5affab656d752ed5e90b6dce2650e97d91a10384 (patch)
tree388df5105a27e5e7e332f7ab9c29c42b84d30769 /debian/rules
parent567e66fb3efca2199c6b7f7383c72c1df03f1a61 (diff)
set RTE_MACHINE after potential external override
Change-Id: I4bfa59886592511af7ebe6c6d78014675d0a3173 Signed-off-by: Christian Ehrhardt <christian.ehrhardt@canonical.com>
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules6
1 files changed, 3 insertions, 3 deletions
diff --git a/debian/rules b/debian/rules
index b88051ef..a2c553c8 100755
--- a/debian/rules
+++ b/debian/rules
@@ -12,14 +12,14 @@ ifeq (,$(findstring terse,$(DEB_BUILD_OPTIONS)))
export DH_OPTIONS=-v
endif
-# default to minimal base, without setting this it would build
-# -march=native which is a non portable invariant
-RTE_MACHINE ?= "default"
# People rebuilding this package can overwrite RTE_MACHINE
# via DEB_BUILD_OPTIONS if they like
ifneq (,$(filter rte_machine=%,$(DEB_BUILD_OPTIONS)))
RTE_MACHINE ?= $(patsubst rte_machine=%,%,$(filter rte_machine=%,$(DEB_BUILD_OPTIONS)))
endif
+# default to minimal base, without setting this it would build
+# -march=native which is a non portable invariant
+RTE_MACHINE ?= "default"
# now stable with parallel comilation, so support -j
ifneq (,$(filter parallel=%,$(DEB_BUILD_OPTIONS)))