aboutsummaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorLuca Boccassi <luca.boccassi@gmail.com>2017-08-03 16:50:07 +0100
committerLuca Boccassi <luca.boccassi@gmail.com>2017-08-03 17:18:33 +0100
commitea1a9bc7d8af4e18b7615923c70d0be06764c311 (patch)
tree47174d7b2138699eb46e8174a07b5e26119b01ed /debian/rules
parent7b2fcb3f0e78e8abe77336f5687ce876e49efeb2 (diff)
Use arch-dependent include directory in DKMS confs
Generate them at build time to substitute the right directory per architecture to fix the build. Change-Id: Ib6ba0820a27a4cc38d5e11dc94d35f1adece1453 Signed-off-by: Luca Boccassi <luca.boccassi@gmail.com>
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules4
1 files changed, 4 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index 25d77e08..b1357b24 100755
--- a/debian/rules
+++ b/debian/rules
@@ -166,6 +166,7 @@ override_dh_auto_clean:
debian/control.modules debian/VERSION
sed -i '/Package: dpdk-modules-/,/`tail -n1 debian/control.modules.in`/d' debian/control
test -L config/defconfig_$(DPDK_CONFIG) && rm -f config/defconfig_$(DPDK_CONFIG) || true
+ rm -f debian/dpdk-igb-uio-dkms.dkms debian/dpdk-rte-kni-dkms.dkms
override_dh_auto_configure:
# Add support for a custom defconfig file in the debian directory.
@@ -283,6 +284,9 @@ ifeq (x86_64-linux-gnu,$(DEB_HOST_MULTIARCH))
ln -rs debian/libdpdk-dev/usr/include/$(DEB_HOST_MULTIARCH)/dpdk/*.h \
debian/libdpdk-dev/usr/include/dpdk
endif
+ # have the DKMS build include the correct per-arch directory
+ sed "s/@@DEB_HOST_MULTIARCH@@/$(DEB_HOST_MULTIARCH)/g" debian/dpdk-igb-uio-dkms.dkms.in > debian/dpdk-igb-uio-dkms.dkms
+ sed "s/@@DEB_HOST_MULTIARCH@@/$(DEB_HOST_MULTIARCH)/g" debian/dpdk-rte-kni-dkms.dkms.in > debian/dpdk-rte-kni-dkms.dkms
# all static libs are in the dev package
ifeq (y,$(BUILD_STATIC_LIB))
mv debian/dpdk/$(LIBDIR)/lib*.a debian/libdpdk-dev/$(LIBDIR)/