aboutsummaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorChristian Ehrhardt <christian.ehrhardt@canonical.com>2017-02-07 15:00:39 +0100
committerChristian Ehrhardt <christian.ehrhardt@canonical.com>2017-02-07 15:48:12 +0100
commit59b0879e6beaf61f707ac4b44aac8fa90146b125 (patch)
tree504986caef563421cd60b7eff1bea6433879031d /debian/rules
parent1e347795ba76a1657040db950a039f7c7ba95394 (diff)
provide old ABI levels via backward compatibility of new DPDK libraries.
The cross dependencies in DPDK libraries would force us to conflict with older ABI versions to avoid double ld.so resolution (https://lists.ubuntu.com/archives/ubuntu-devel/2017-February/039659.html) The conflicts would make the old versions and thereby the dependent applications non-installable until there is a rebuild (as other updates would do). But for our case that would deny most benefits of version named libraries. Instead of adding a conflicts - whenever possible - provide a backward compatible wrapper symlinking to the new (ABI compatible) implementation. Change-Id: If9fa9cb9474ad0ac555bdf1a0c72f701ddaf2926 Signed-off-by: Christian Ehrhardt <christian.ehrhardt@canonical.com>
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules15
1 files changed, 15 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index 4033b17f..321f3681 100755
--- a/debian/rules
+++ b/debian/rules
@@ -126,6 +126,12 @@ override_dh_auto_clean:
sed -i '/Package: dpdk-modules-/,/`tail -n1 debian/control.modules.in`/d' debian/control
test -L config/defconfig_$(DPDK_CONFIG) && rm -f config/defconfig_$(DPDK_CONFIG) || true
+override_dh_clean:
+ dh_clean
+ rm -f debian/libethdev4.links
+ rm -f debian/librte-cryptodev1.links
+ rm -f debian/librte-eal2.links
+
override_dh_auto_configure:
# Add support for a custom defconfig file in the debian directory.
ifneq (,$(filter dpdk_config=%,$(DEB_BUILD_OPTIONS)))
@@ -264,6 +270,15 @@ ifneq (,$(KVERS))
debian/dpdk-modules-$(KVERS)/lib/modules/$(KVERS)/kernel/drivers/net
endif
+debian/libethdev4.links: debian/libethdev4.links.in
+ sed -e 's/@DEB_HOST_MULTIARCH@/$(DEB_HOST_MULTIARCH)/g' < $< > $@
+debian/librte-cryptodev1.links: debian/librte-cryptodev1.links.in
+ sed -e 's/@DEB_HOST_MULTIARCH@/$(DEB_HOST_MULTIARCH)/g' < $< > $@
+debian/librte-eal2.links: debian/librte-eal2.links.in
+ sed -e 's/@DEB_HOST_MULTIARCH@/$(DEB_HOST_MULTIARCH)/g' < $< > $@
+override_dh_link: debian/libethdev4.links debian/librte-cryptodev1.links debian/librte-eal2.links
+ dh_link
+
override_dh_dkms:
dh_dkms -V $(VERSION)