aboutsummaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorChristian Ehrhardt <christian.ehrhardt@canonical.com>2017-05-16 16:28:06 +0200
committerChristian Ehrhardt <christian.ehrhardt@canonical.com>2017-05-17 15:05:06 +0200
commitb6e2851b0b721865a51ddbdafffdee5f57f88396 (patch)
tree45896a400e1538691bc49b507325a87cd546f128 /debian/rules
parent630620939cb681826851bf13c225b4cb89d6aa07 (diff)
debian/rules: adapt new location and build of tests
Build test tools which is now split from default build. We want those as we already provided a few of them together with the dpdk-dev package as helpers. Since we want only those from the shared (not the static) build we only add the shared ones. Also along that some paths changed which had to be adapted. This will add testacl and testpipeline tools and unify them with the already provided test and testpmd tools in one directory. Due to that testpmd will no more be in path, but that is correct given that it is a test/dev tool more than a normal end user binary. Change-Id: Ice383b5a70fe26fcd12864a0a86eebe114272108 Signed-off-by: Christian Ehrhardt <christian.ehrhardt@canonical.com>
Diffstat (limited to 'debian/rules')
-rw-r--r--debian/rules5
1 files changed, 4 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index e6607b11..04a9d024 100644
--- a/debian/rules
+++ b/debian/rules
@@ -185,6 +185,7 @@ override_dh_auto_build-arch:
sed -ri 's,(RTE_BUILD_SHARED_LIB=).*,\1y,' \
$(DPDK_SHARED_DIR)/.config
$(MAKE) -j $(PAR) V=$(DH_VERBOSE) O=$(DPDK_SHARED_DIR) RTE_KERNELDIR=$(KSRC) build
+ $(MAKE) -j $(PAR) V=$(DH_VERBOSE) O=$(DPDK_SHARED_DIR) RTE_KERNELDIR=$(KSRC) test-build
override_dh_auto_install-arch: LIBDIR=/usr/lib/$(shell dpkg-architecture -qDEB_HOST_MULTIARCH)
override_dh_auto_install-arch:
@@ -211,8 +212,10 @@ override_dh_auto_install-arch:
debian/dpdk-dev/usr/share/dpdk/dpdk-sdk-env.sh
# include the bundled autotest suite to be usable from the dpdk-dev package
mkdir -p debian/dpdk-dev/usr/share/dpdk/test
- cp -a app/test/autotest* debian/dpdk-dev/usr/share/dpdk/test
+ cp -a test/test/autotest* debian/dpdk-dev/usr/share/dpdk/test
cp $(DPDK_SHARED_DIR)/app/test debian/dpdk-dev/usr/share/dpdk/test/
+ cp $(DPDK_SHARED_DIR)/app/testacl debian/dpdk-dev/usr/share/dpdk/test/
+ cp $(DPDK_SHARED_DIR)/app/testpipeline debian/dpdk-dev/usr/share/dpdk/test/
# since we move libs to multiarch dirs update the non aware symlink
rm debian/dpdk-dev/usr/share/dpdk/$(RTE_TARGET)/lib
ln -rs debian/dpdk-dev/$(LIBDIR)/ \