aboutsummaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorLuca Boccassi <luca.boccassi@gmail.com>2017-05-18 19:21:38 +0100
committerLuca Boccassi <luca.boccassi@gmail.com>2017-05-18 19:21:38 +0100
commit155e2da43497ec305ae7e716a0f34056ea708855 (patch)
tree63ebf41ff6f241e1397e597d36694e04e33ca74b /debian/rules
parentcbb89ef6a1840a065940aae10f1d290a2b0d229f (diff)
Add option to disable docs build
Takes some good time to build the documentation, so add a DEB_BUILD_OPTIONS nodocs variable to let users disable it. Change-Id: I8cb44d31329367784d2987ecba008143be089376 Signed-off-by: Luca Boccassi <luca.boccassi@gmail.com>
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules10
1 files changed, 10 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index 9e272aa6..5d2f1590 100755
--- a/debian/rules
+++ b/debian/rules
@@ -75,6 +75,12 @@ else
PAR := "1"
endif
+ifneq (,$(findstring nodocs,$(DEB_BUILD_OPTIONS)))
+BUILD_DOCS=n
+else
+BUILD_DOCS=y
+endif
+
# kernel_modules can be passed via DEB_BUILD_OPTIONS to enable building the
# optional binary kernel modules package. By default it will be built against
# the current kernel, or ksrc can be passed with a path to the target kernel
@@ -159,14 +165,18 @@ endif
dh_auto_configure
override_dh_auto_build-indep:
+ifeq (y,$(BUILD_DOCS))
$(MAKE) -j $(PAR) V=$(DH_VERBOSE) O=$(DPDK_STATIC_DIR) doc-api-html doc-guides-html \
doc-guides-man
+endif
override_dh_auto_install-indep:
# Package: dpdk-doc
# All files based on the install-doc rule (includes examples)
+ifeq (y,$(BUILD_DOCS))
$(MAKE) V=$(DH_VERBOSE) O=$(DPDK_STATIC_DIR) prefix=/usr \
DESTDIR=debian/dpdk-doc install-doc
+endif
override_dh_auto_build-arch:
$(MAKE) -j $(PAR) V=$(DH_VERBOSE) O=$(DPDK_STATIC_DIR) RTE_KERNELDIR=$(KSRC) build