aboutsummaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorChristian Ehrhardt <christian.ehrhardt@canonical.com>2016-06-23 09:47:13 +0200
committerChristian Ehrhardt <christian.ehrhardt@canonical.com>2016-06-23 16:39:48 +0200
commit2197f11c1ce454c6968a21698ff43e43611cb4fd (patch)
tree95ffde3e4c5d0fcdf5e3a8687cf3be8cfd6c6bd4 /debian/rules
parente35f05401a47bf0b69c813e6450bc52c89652931 (diff)
d/rules: allow external override of base dpdk configuration
By using := instead of = users that rebuild our packaging can overwrite the following via environment variables: DPDK_CONFIG RTE_MACHINE RTE_TARGET That is already used by some consumers of the Ubuntu packaging to get optimized build, but would allow them to go on without a patch on top. Also since it is a no-op, as long as the variables are not set, it is fairly safe. Change-Id: I26265c09c90d33a6e4cd37f8c26ac0ef5baac0c4 Signed-off-by: Christian Ehrhardt <christian.ehrhardt@canonical.com>
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules14
1 files changed, 8 insertions, 6 deletions
diff --git a/debian/rules b/debian/rules
index e8bf409d..fa9cf7e3 100755
--- a/debian/rules
+++ b/debian/rules
@@ -24,14 +24,16 @@ export EXTRA_CFLAGS = -g -fPIC
# package maintainers to append LDFLAGS
#export DEB_LDFLAGS_MAINT_APPEND = -Wl,--as-needed
+# People rebuilding this package can overwrite DPDK_CONFIG, RTE_MACHINE and
+# RTE_TARGET via environment variables if they like
ifneq (,$(filter $(DEB_HOST_ARCH), arm64))
-DPDK_CONFIG = "arm64-armv8a-linuxapp-gcc"
-RTE_MACHINE = "armv8a"
-RTE_TARGET = "arm64-armv8a-linuxapp-gcc"
+DPDK_CONFIG := "arm64-armv8a-linuxapp-gcc"
+RTE_MACHINE := "armv8a"
+RTE_TARGET := "arm64-armv8a-linuxapp-gcc"
else
-DPDK_CONFIG = "$(DEB_HOST_GNU_CPU)-native-linuxapp-gcc"
-RTE_MACHINE = "default"
-RTE_TARGET = "$(DEB_HOST_GNU_CPU)-default-linuxapp-gcc"
+DPDK_CONFIG := "$(DEB_HOST_GNU_CPU)-native-linuxapp-gcc"
+RTE_MACHINE := "default"
+RTE_TARGET := "$(DEB_HOST_GNU_CPU)-default-linuxapp-gcc"
endif
DPDK_STATIC_DIR = "debian/build/static-root"
DPDK_SHARED_DIR = "debian/build/shared-root"