aboutsummaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorChristian Ehrhardt <christian.ehrhardt@canonical.com>2016-06-23 10:13:33 +0200
committerChristian Ehrhardt <christian.ehrhardt@canonical.com>2016-06-23 16:39:48 +0200
commit4801b3f332b1d19019691b664cb54977d6a9d93f (patch)
treeb5a67504792ed82ba9b83c4d95d52a26826bfeda /debian/rules
parent3ae0af121309b8ab3f9c93ab8e70d992a223109d (diff)
fix package names to match sonames
Following policy and fixing the warning regarding https://lintian.debian.org/tags/package-name-doesnt-match-sonames.html Change-Id: Ib946075ff64c0f1c30e32f7998a3aa99256ebce5 Signed-off-by: Christian Ehrhardt <christian.ehrhardt@canonical.com>
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules7
1 files changed, 3 insertions, 4 deletions
diff --git a/debian/rules b/debian/rules
index fa9cf7e3..640ed3aa 100755
--- a/debian/rules
+++ b/debian/rules
@@ -148,10 +148,9 @@ binary-arch:
BN=$$(basename $${lib}); \
VER=$$(echo $${BN} | sed -e 's/^.*\.so\.//'); \
LN=$$(echo $${BN} | sed -e 's/\.so\.[0-9]*$$//' | tr '_' '-'); \
- LNV="libdpdk-$${LN}$${VER}"; \
- echo "moving $${lib} for library $${LNV}"; \
- mkdir -p debian/$${LNV}/$(LIBDIR); \
- mv $${lib} debian/$${LNV}/$(LIBDIR); \
+ echo "moving $${lib} for library $${LN}$${VER}"; \
+ mkdir -p debian/$${LN}$${VER}/$(LIBDIR); \
+ mv $${lib} debian/$${LN}$${VER}/$(LIBDIR); \
done
# Package: dpdk-igb-uio-dkms
mkdir -p debian/dpdk-igb-uio-dkms/usr/src/dpdk-igb-uio-$(VERSION)