aboutsummaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorChristian Ehrhardt <christian.ehrhardt@canonical.com>2016-06-23 13:54:37 +0200
committerC.J. Collier <cjcollier@linuxfoundation.org>2016-06-23 08:54:19 -0700
commit4e640f19a342cfbb04a910eae0128a7fdac959f8 (patch)
treea5deb535a7ec7e816714e1e3d13afdce86e43288 /debian/rules
parent76c637cafeeb86ce5abb8c8029b1f49d04d4d892 (diff)
d/rules: make build more verbose by default
With so many changes to linking, flags and also our plan for further optimization along the way it is useful to make the build more verbose by default to spot issues right in the main build log. Change-Id: I0c41d232bc7b353b9e8a91e7e3934a9b4a3a46cc Signed-off-by: Christian Ehrhardt <christian.ehrhardt@canonical.com> Signed-off-by: C.J. Collier <cjcollier@linuxfoundation.org>
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules7
1 files changed, 4 insertions, 3 deletions
diff --git a/debian/rules b/debian/rules
index 640ed3aa..f262b48d 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,7 +1,8 @@
#!/usr/bin/make -f
# See debhelper(7) (uncomment to enable)
# output every command that modifies files on the build system.
-#export DH_VERBOSE = 1
+export DH_VERBOSE=1
+export DH_OPTIONS=-v
VERSION := $(shell dpkg-parsechangelog | sed -nr '/^Version:/s/Version: (.*:)?(.*)-(.*)/\2/p')
@@ -60,7 +61,7 @@ build-indep: build-config
build-arch: build-config
dh_testdir
- $(MAKE) O=$(DPDK_STATIC_DIR) build
+ $(MAKE) V=$(DH_VERBOSE) O=$(DPDK_STATIC_DIR) build
# Unfortunately the decision about having static or shared libraries is
# made for the whole build, which then produces only .a or .so files
# (but not both).
@@ -73,7 +74,7 @@ build-arch: build-config
cp -a $(DPDK_STATIC_DIR) $(DPDK_SHARED_DIR)
sed -ri 's,(RTE_BUILD_SHARED_LIB=).*,\1y,' \
$(DPDK_SHARED_DIR)/.config
- $(MAKE) O=$(DPDK_SHARED_DIR) build
+ $(MAKE) V=$(DH_VERBOSE) O=$(DPDK_SHARED_DIR) build
build: build-arch build-indep