aboutsummaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorLuca Boccassi <luca.boccassi@gmail.com>2017-06-19 15:24:19 +0100
committerLuca Boccassi <luca.boccassi@gmail.com>2017-06-19 15:24:56 +0100
commit54fdfb34cf12b97eda316e3945fa2ece0bfb9ffb (patch)
tree21ae20b49f6a9205871e2fc3df84f783fff95318 /debian/rules
parent626a379f6211f4faa4ac634a4ec855ab9c1e5dd4 (diff)
Adjust install path for UTs and check config first
Do not try to copy the unit test binaries if the config is not enabled. Change-Id: I339eac3b5bfae351085aebb69adbacac99790c03 Signed-off-by: Luca Boccassi <luca.boccassi@gmail.com>
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules12
1 files changed, 7 insertions, 5 deletions
diff --git a/debian/rules b/debian/rules
index 068fd8e1..a6c897b6 100755
--- a/debian/rules
+++ b/debian/rules
@@ -252,11 +252,13 @@ endif
sed -e 's/SDK_TARGET/$(RTE_TARGET)/' debian/dpdk-sdk-env.sh.in > \
debian/dpdk-dev/usr/share/dpdk/dpdk-sdk-env.sh
# include the bundled autotest suite to be usable from the dpdk-dev package
- mkdir -p debian/dpdk-dev/usr/share/dpdk/test
- cp -a test/test/autotest* debian/dpdk-dev/usr/share/dpdk/test
- cp $(DPDK_SHARED_DIR)/app/test debian/dpdk-dev/usr/share/dpdk/test/
- cp $(DPDK_SHARED_DIR)/app/testacl debian/dpdk-dev/usr/share/dpdk/test/
- cp $(DPDK_SHARED_DIR)/app/testpipeline debian/dpdk-dev/usr/share/dpdk/test/
+ if grep -qs 'CONFIG_RTE_APP_TEST=y' $(DPDK_SHARED_DIR)/.config; then \
+ mkdir -p debian/dpdk-dev/usr/share/dpdk/test; \
+ cp -a test/test/autotest* debian/dpdk-dev/usr/share/dpdk/test; \
+ cp -r $(DPDK_SHARED_DIR)/test debian/dpdk-dev/usr/share/dpdk/test; \
+ cp -r $(DPDK_SHARED_DIR)/testacl debian/dpdk-dev/usr/share/dpdk/test; \
+ cp -r $(DPDK_SHARED_DIR)/testpipeline debian/dpdk-dev/usr/share/dpdk/test; \
+ fi
# since we move libs to multiarch dirs update the non aware symlink
rm debian/dpdk-dev/usr/share/dpdk/$(RTE_TARGET)/lib
ln -rs debian/dpdk-dev/$(LIBDIR)/ \