aboutsummaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorChristian Ehrhardt <christian.ehrhardt@canonical.com>2017-05-16 16:28:06 +0200
committerLuca Boccassi <luca.boccassi@gmail.com>2017-06-20 16:26:32 +0100
commit91bd1b4a799800966789e4c28de7b34f3bd42499 (patch)
treec64f3cd2251e5012b0405a573b165647536c471a /debian/rules
parent86f9f751005f8fa5a89eb18ac4c8a593322cc880 (diff)
debian/rules: adapt new location and build of tests
Build test tools which is now split from default build. We want those as we already provided a few of them together with the dpdk-dev package as helpers. Since we want only those from the shared (not the static) build we only add the shared ones. Also along that some paths changed which had to be adapted. This will add testacl and testpipeline tools and unify them with the already provided test and testpmd tools in one directory. Due to that testpmd will no more be in path, but that is correct given that it is a test/dev tool more than a normal end user binary. Change-Id: Ice383b5a70fe26fcd12864a0a86eebe114272108 Signed-off-by: Luca Boccassi <luca.boccassi@gmail.com> Signed-off-by: Christian Ehrhardt <christian.ehrhardt@canonical.com>
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules7
1 files changed, 4 insertions, 3 deletions
diff --git a/debian/rules b/debian/rules
index a6c897b6..61543b54 100755
--- a/debian/rules
+++ b/debian/rules
@@ -225,6 +225,7 @@ ifeq (y,$(BUILD_DOCS))
# need to be around for dh_installman to be picked up
$(MAKE) V=$(DH_VERBOSE) O=$(DPDK_SHARED_DIR) RTE_KERNELDIR=$(KSRC) doc-guides-man
endif
+ $(MAKE) V=$(DH_VERBOSE) O=$(DPDK_SHARED_DIR) RTE_KERNELDIR=$(KSRC) test-build
override_dh_auto_install-arch: LIBDIR=/usr/lib/$(shell dpkg-architecture -qDEB_HOST_MULTIARCH)
override_dh_auto_install-arch:
@@ -255,9 +256,9 @@ endif
if grep -qs 'CONFIG_RTE_APP_TEST=y' $(DPDK_SHARED_DIR)/.config; then \
mkdir -p debian/dpdk-dev/usr/share/dpdk/test; \
cp -a test/test/autotest* debian/dpdk-dev/usr/share/dpdk/test; \
- cp -r $(DPDK_SHARED_DIR)/test debian/dpdk-dev/usr/share/dpdk/test; \
- cp -r $(DPDK_SHARED_DIR)/testacl debian/dpdk-dev/usr/share/dpdk/test; \
- cp -r $(DPDK_SHARED_DIR)/testpipeline debian/dpdk-dev/usr/share/dpdk/test; \
+ cp $(DPDK_SHARED_DIR)/app/test debian/dpdk-dev/usr/share/dpdk/test/; \
+ cp $(DPDK_SHARED_DIR)/app/testacl debian/dpdk-dev/usr/share/dpdk/test/; \
+ cp $(DPDK_SHARED_DIR)/app/testpipeline debian/dpdk-dev/usr/share/dpdk/test/; \
fi
# since we move libs to multiarch dirs update the non aware symlink
rm debian/dpdk-dev/usr/share/dpdk/$(RTE_TARGET)/lib