aboutsummaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorLuca Boccassi <bluca@debian.org>2018-11-02 16:50:27 +0000
committerLuca Boccassi <luca.boccassi@gmail.com>2018-11-13 11:18:30 +0000
commitda1af9ba4305c71f18a11e9206cdbdfc5eb36cbd (patch)
treee3286c6976712a352eea1a9b1b52fde98dce36a1 /debian/rules
parent5ed8cf567ae573c44fbbb7dea74f6e6fd3f50524 (diff)
Drop libdpdk-dbgsym - not really used and broken in sid
debhelper tools got stricter on acting on packages missing from debian/control, so the generation of libdpdk-dbgsym is broken. It was always a hack anyway since dbgsym are not supposed to be created manually Change-Id: I423e7006049a48085686dfea5c3dc106ec86217a Signed-off-by: Luca Boccassi <luca.boccassi@gmail.com>
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules17
1 files changed, 1 insertions, 16 deletions
diff --git a/debian/rules b/debian/rules
index 3ce83b9e..723c7130 100755
--- a/debian/rules
+++ b/debian/rules
@@ -72,7 +72,7 @@ endif
override_dh_gencontrol:
dh_gencontrol
# debian/files will not exist until dh_gencontrol has ran at least once,
- # so we need to run gencontrol for libdpdk-dev and libdpdk-dbgsym after.
+ # so we need to run gencontrol for libdpdk-dev after.
# The list of libraries and PMDs is everchanging, so generate the dependency
# list for libdpdk-dev to avoid having to maintain it manually.
# Same for the recommends list for dpdk, were we want the PMDs and the mempools.
@@ -83,21 +83,6 @@ ifneq (,$(findstring kernel_modules,$(DEB_BUILD_OPTIONS)))
-v`cat debian/VERSION` \
-V'built:using:kernel=$(call get_built_using,linux-headers-$(KVERS))'
endif
-ifneq (,$(findstring dbgsym_meta,$(DEB_BUILD_OPTIONS)))
- ./debian/dh-dbgsym-metapkg libdpdk$(DPDK_ABI)-dbgsym
-endif
-
-# dbgsym_meta can be passed via DEB_BUILD_OPTIONS to enable building the
-# optional dbgsym meta package libdpdk<ABI>-dbgsym.
-# This is not built by default as it would go in main but depend on
-# packages in the debian-debug archive.
-# Debian Developers and FTP masters strongly discourage this.
-# We provide this optional flag as a convenience for rebuilders.
-ifneq (,$(findstring dbgsym_meta,$(DEB_BUILD_OPTIONS)))
-override_dh_builddeb:
- dh_builddeb
- dh_builddeb -plibdpdk$(DPDK_ABI)-dbgsym
-endif
override_dh_auto_clean:
rm -rf debian/build debian/tmp debian/dpdk-modules-* \