aboutsummaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorChristian Ehrhardt <christian.ehrhardt@canonical.com>2016-09-12 11:53:51 +0200
committerChristian Ehrhardt <christian.ehrhardt@canonical.com>2016-09-12 11:58:27 +0200
commite23cec6cdc0e170cfe9ee0fa10b07b5f1476622c (patch)
tree3f117daeb332d897a44ee4b34a898357ac2d1256 /debian/rules
parent41383c91c3b352681dc97aa6c1ad48caaaf23ecb (diff)
build: enable powerpc
Enable ppc64el to build supported packages on that architecture as well. xen dependencies are not available on ppc64el, so disable xen pmd in that case. powerpc currently has several libraries and pmds disabled in its default dpdk config. That defines the range of expected-to-work packages. Follow that and remove ppc64el architecture on those libs and pmds as packages. Change-Id: I7f18962ad9e021c42e80739ddd569db4ecfe65dc Signed-off-by: Christian Ehrhardt <christian.ehrhardt@canonical.com> Change-Id: Ic0bb0741f4027dd4ed371e3228aa770fb3b698f9 Signed-off-by: Christian Ehrhardt <christian.ehrhardt@canonical.com>
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules10
1 files changed, 10 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index d4b09dfe..32673763 100755
--- a/debian/rules
+++ b/debian/rules
@@ -37,10 +37,16 @@ DPDK_CONFIG := "arm64-armv8a-linuxapp-gcc"
RTE_MACHINE := "armv8a"
RTE_TARGET := "arm64-armv8a-linuxapp-gcc"
else
+ifneq (,$(filter $(DEB_HOST_ARCH), ppc64el))
+DPDK_CONFIG := "ppc_64-power8-linuxapp-gcc"
+RTE_MACHINE := "power8"
+RTE_TARGET := "ppc_64-power8-linuxapp-gcc"
+else
DPDK_CONFIG := "$(DEB_HOST_GNU_CPU)-native-linuxapp-gcc"
RTE_MACHINE := "default"
RTE_TARGET := "$(DEB_HOST_GNU_CPU)-default-linuxapp-gcc"
endif
+endif
DPDK_STATIC_DIR = "debian/build/static-root"
DPDK_SHARED_DIR = "debian/build/shared-root"
@@ -106,6 +112,10 @@ override_dh_auto_configure:
-e 's,(LIBRTE_PMD_PCAP=).*,\1y,' \
-e 's,(LIBRTE_PMD_XENVIRT=).*,\1y,' \
$(DPDK_STATIC_DIR)/.config
+ # xen not available on ppc64el
+ifneq (,$(filter $(DEB_HOST_ARCH), ppc64el))
+ sed -ri -e 's,(LIBRTE_PMD_XENVIRT=).*,\1n,' $(DPDK_STATIC_DIR)/.config
+endif
dh_auto_configure
override_dh_auto_build-indep: