aboutsummaryrefslogtreecommitdiffstats
path: root/debian
diff options
context:
space:
mode:
authorLuca Boccassi <luca.boccassi@gmail.com>2017-11-08 14:33:34 +0000
committerLuca Boccassi <luca.boccassi@gmail.com>2017-11-08 18:22:19 +0000
commit77a3203132dc8680b6bf71ca25d417e8d9c2b84b (patch)
tree11c641051b3cd322dc5bd0a0ef7d88379fb30b34 /debian
parent6afc10c669eee72f16900fef5acc6eb1c9221a4a (diff)
Drop repro build patches, merged upstream
Change-Id: I8078584e295d5822c2adcf1f7cecec97efdbada1 Signed-off-by: Luca Boccassi <luca.boccassi@gmail.com>
Diffstat (limited to 'debian')
-rw-r--r--debian/patches/mk-install-symlinks-before-build-step.patch48
-rw-r--r--debian/patches/mk-sort-headers-before-wildcard-inclusion.patch72
-rw-r--r--debian/patches/mk-sort-list-of-files-in-examples.dox.patch31
-rw-r--r--debian/patches/mk-sort-list-of-shared-objects-in-linker-script.patch32
-rw-r--r--debian/patches/mk-sort-object-files-when-building-deps-lists.patch64
-rw-r--r--debian/patches/mk-sort-source-files-before-passing-them-to-the-comp.patch127
-rw-r--r--debian/patches/series6
7 files changed, 0 insertions, 380 deletions
diff --git a/debian/patches/mk-install-symlinks-before-build-step.patch b/debian/patches/mk-install-symlinks-before-build-step.patch
deleted file mode 100644
index 42569269..00000000
--- a/debian/patches/mk-install-symlinks-before-build-step.patch
+++ /dev/null
@@ -1,48 +0,0 @@
-Description: mk: install symlinks before build step
-
-A race condition can happen during parallel builds, where a header
-might be installed in RTE_OUT/include before CFLAGS is recursively
-expanded. This causes GCC to sometimes pick the header path as
-SRCDIR/... and sometimes as RTE_OUT/include/... making the build
-unreproducible, as the full path is used for the expansion of
-__FILE__ and in the DWARF directory listing.
-
-Installing all symlinks before all builds solves the problem. It is
-still suboptimal, as the (fixed) path recorded in the DWARF dir
-listing will include the user-configurable build output directory,
-and thus will result in a different binary between different users
-despite all other conditions being equal, but it is a simpler
-approach that will anyway be obsolete once the build system is
-switched to Meson.
-
-Origin: http://dpdk.org/dev/patchwork/patch/28391/
-Forwarded: yes
-Author: Luca Boccassi <luca.boccassi@gmail.com>
-Last-Update: 2017-09-05
----
- mk/rte.lib.mk | 7 ++++++-
- 1 file changed, 6 insertions(+), 1 deletion(-)
-
---- a/mk/rte.lib.mk
-+++ b/mk/rte.lib.mk
-@@ -59,14 +59,19 @@ endif
-
-
- _BUILD = $(LIB)
--_INSTALL = $(INSTALL-FILES-y) $(SYMLINK-FILES-y) $(RTE_OUTPUT)/lib/$(LIB)
-+PREINSTALL = $(SYMLINK-FILES-y)
-+_INSTALL = $(INSTALL-FILES-y) $(RTE_OUTPUT)/lib/$(LIB)
- _CLEAN = doclean
-
- .PHONY: all
- all: install
-
- .PHONY: install
-+ifeq ($(SYMLINK-FILES-y),)
- install: build _postinstall
-+else
-+install: _preinstall build _postinstall
-+endif
-
- _postinstall: build
-
diff --git a/debian/patches/mk-sort-headers-before-wildcard-inclusion.patch b/debian/patches/mk-sort-headers-before-wildcard-inclusion.patch
deleted file mode 100644
index 332a88e7..00000000
--- a/debian/patches/mk-sort-headers-before-wildcard-inclusion.patch
+++ /dev/null
@@ -1,72 +0,0 @@
-Description: mk: sort headers before wildcard inclusion
-
-In order to achieve fully reproducible builds, always use the same
-inclusion order for headers in the Makefiles.
-
-Origin: http://dpdk.org/dev/patchwork/patch/27509/
-Forwarded: yes
-Author: Luca Boccassi <luca.boccassi@gmail.com>
-Last-Update: 2017-08-10
----
- examples/ip_pipeline/Makefile | 2 +-
- examples/multi_process/client_server_mp/mp_server/Makefile | 2 +-
- examples/server_node_efd/server/Makefile | 2 +-
- lib/librte_eal/common/Makefile | 2 +-
- 4 files changed, 4 insertions(+), 4 deletions(-)
-
-diff --git a/examples/ip_pipeline/Makefile b/examples/ip_pipeline/Makefile
-index dc7e0ddd7..12ce0a1d5 100644
---- a/examples/ip_pipeline/Makefile
-+++ b/examples/ip_pipeline/Makefile
-@@ -43,7 +43,7 @@ APP = ip_pipeline
-
- VPATH += $(SRCDIR)/pipeline
-
--INC += $(wildcard *.h) $(wildcard pipeline/*.h)
-+INC += $(sort $(wildcard *.h)) $(sort $(wildcard pipeline/*.h))
-
- # all source are stored in SRCS-y
- SRCS-$(CONFIG_RTE_LIBRTE_PIPELINE) := main.c
-diff --git a/examples/multi_process/client_server_mp/mp_server/Makefile b/examples/multi_process/client_server_mp/mp_server/Makefile
-index 5552999b5..160c17b68 100644
---- a/examples/multi_process/client_server_mp/mp_server/Makefile
-+++ b/examples/multi_process/client_server_mp/mp_server/Makefile
-@@ -49,7 +49,7 @@ APP = mp_server
- # all source are stored in SRCS-y
- SRCS-y := main.c init.c args.c
-
--INC := $(wildcard *.h)
-+INC := $(sort $(wildcard *.h))
-
- CFLAGS += $(WERROR_FLAGS) -O3
- CFLAGS += -I$(SRCDIR)/../shared
-diff --git a/examples/server_node_efd/server/Makefile b/examples/server_node_efd/server/Makefile
-index a2f2f361b..9f1fe2894 100644
---- a/examples/server_node_efd/server/Makefile
-+++ b/examples/server_node_efd/server/Makefile
-@@ -49,7 +49,7 @@ APP = server
- # all source are stored in SRCS-y
- SRCS-y := main.c init.c args.c
-
--INC := $(wildcard *.h)
-+INC := $(sort $(wildcard *.h))
-
- CFLAGS += $(WERROR_FLAGS) -O3
- CFLAGS += -I$(SRCDIR)/../shared
-diff --git a/lib/librte_eal/common/Makefile b/lib/librte_eal/common/Makefile
-index a5bd1089a..4b712600a 100644
---- a/lib/librte_eal/common/Makefile
-+++ b/lib/librte_eal/common/Makefile
-@@ -48,7 +48,7 @@ GENERIC_INC += rte_vect.h rte_io.h
-
- # defined in mk/arch/$(RTE_ARCH)/rte.vars.mk
- ARCH_DIR ?= $(RTE_ARCH)
--ARCH_INC := $(notdir $(wildcard $(RTE_SDK)/lib/librte_eal/common/include/arch/$(ARCH_DIR)/*.h))
-+ARCH_INC := $(sort $(notdir $(wildcard $(RTE_SDK)/lib/librte_eal/common/include/arch/$(ARCH_DIR)/*.h)))
-
- SYMLINK-$(CONFIG_RTE_LIBRTE_EAL)-include := $(addprefix include/,$(INC))
- SYMLINK-$(CONFIG_RTE_LIBRTE_EAL)-include += \
---
-2.11.0
-
-
diff --git a/debian/patches/mk-sort-list-of-files-in-examples.dox.patch b/debian/patches/mk-sort-list-of-files-in-examples.dox.patch
deleted file mode 100644
index 17404ef4..00000000
--- a/debian/patches/mk-sort-list-of-files-in-examples.dox.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-Description: mk: sort list of files in examples.dox
-
-The result of find might not be stable depending on external
-conditions.
-Pipe it through LC_ALL=C sort to ensure reproducible results when
-generating examples.dox.
-
-Origin: http://dpdk.org/dev/patchwork/patch/27508/
-Forwarded: yes
-Author: Luca Boccassi <luca.boccassi@gmail.com>
-Last-Update: 2017-08-10
----
- mk/rte.sdkdoc.mk | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/mk/rte.sdkdoc.mk b/mk/rte.sdkdoc.mk
-index c0eaa3502..de31b78cf 100644
---- a/mk/rte.sdkdoc.mk
-+++ b/mk/rte.sdkdoc.mk
-@@ -93,7 +93,7 @@ $(API_EXAMPLES): api-html-clean
- $(Q)mkdir -p $(@D)
- @printf '/**\n' > $(API_EXAMPLES)
- @printf '@page examples DPDK Example Programs\n\n' >> $(API_EXAMPLES)
-- @find examples -type f -name '*.c' -printf '@example %p\n' >> $(API_EXAMPLES)
-+ @find examples -type f -name '*.c' -printf '@example %p\n' | LC_ALL=C sort >> $(API_EXAMPLES)
- @printf '*/\n' >> $(API_EXAMPLES)
-
- guides-pdf-clean: guides-pdf-img-clean
---
-2.11.0
-
diff --git a/debian/patches/mk-sort-list-of-shared-objects-in-linker-script.patch b/debian/patches/mk-sort-list-of-shared-objects-in-linker-script.patch
deleted file mode 100644
index 1d3d8b86..00000000
--- a/debian/patches/mk-sort-list-of-shared-objects-in-linker-script.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-Description: mk: sort list of shared objects in linker script
-
-The output of wildcard might not be stable and depend on the
-filesystem and other factors.
-This means the content libdpdk.so linker script might change between
-builds from the same sources.
-Run the list through sort to ensure reproducibility.
-
-Origin: http://dpdk.org/dev/patchwork/patch/27507/
-Forwarded: yes
-Author: Luca Boccassi <luca.boccassi@gmail.com>
-Last-Update: 2017-08-10
----
- mk/rte.combinedlib.mk | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/mk/rte.combinedlib.mk b/mk/rte.combinedlib.mk
-index 449358b33..2ab7ee8a1 100644
---- a/mk/rte.combinedlib.mk
-+++ b/mk/rte.combinedlib.mk
-@@ -42,7 +42,7 @@ endif
- RTE_LIBNAME := dpdk
- COMBINEDLIB := lib$(RTE_LIBNAME)$(EXT)
-
--LIBS := $(filter-out $(COMBINEDLIB), $(notdir $(wildcard $(RTE_OUTPUT)/lib/*$(EXT))))
-+LIBS := $(filter-out $(COMBINEDLIB), $(sort $(notdir $(wildcard $(RTE_OUTPUT)/lib/*$(EXT)))))
-
- all: FORCE
- $(Q)echo "GROUP ( $(LIBS) )" > $(RTE_OUTPUT)/lib/$(COMBINEDLIB)
---
-2.11.0
-
diff --git a/debian/patches/mk-sort-object-files-when-building-deps-lists.patch b/debian/patches/mk-sort-object-files-when-building-deps-lists.patch
deleted file mode 100644
index aa592ddb..00000000
--- a/debian/patches/mk-sort-object-files-when-building-deps-lists.patch
+++ /dev/null
@@ -1,64 +0,0 @@
-Description: mk: sort object files when building deps lists
-
-In order to achieve reproducible builds, always use the same
-order when listing object files to build dependencies lists.
-
-Origin: http://dpdk.org/dev/patchwork/patch/27511/
-Forwarded: yes
-Author: Luca Boccassi <luca.boccassi@gmail.com>
-Last-Update: 2017-08-10
----
- mk/rte.app.mk | 4 ++--
- mk/rte.hostapp.mk | 4 ++--
- mk/rte.shared.mk | 4 ++--
- 3 files changed, 6 insertions(+), 6 deletions(-)
-
-diff --git a/mk/rte.app.mk b/mk/rte.app.mk
-index bcaf1b382..54134dea4 100644
---- a/mk/rte.app.mk
-+++ b/mk/rte.app.mk
-@@ -263,8 +263,8 @@ LDLIBS_NAMES += $(patsubst -Wl$(comma)-l%,lib%.a,$(filter -Wl$(comma)-l%,$(LDLIB
-
- # list of found libraries files (useful for deps). If not found, the
- # library is silently ignored and dep won't be checked
--LDLIBS_FILES := $(wildcard $(foreach dir,$(LDLIBS_PATH),\
-- $(addprefix $(dir)/,$(LDLIBS_NAMES))))
-+LDLIBS_FILES := $(sort $(wildcard $(foreach dir,$(LDLIBS_PATH),\
-+ $(addprefix $(dir)/,$(LDLIBS_NAMES)))))
-
- #
- # Compile executable file if needed
-diff --git a/mk/rte.hostapp.mk b/mk/rte.hostapp.mk
-index 5cb4909cb..f58173c31 100644
---- a/mk/rte.hostapp.mk
-+++ b/mk/rte.hostapp.mk
-@@ -69,9 +69,9 @@ O_TO_EXE_DO = @set -e; \
- -include .$(HOSTAPP).cmd
-
- # list of .a files that are linked to this application
--LDLIBS_FILES := $(wildcard \
-+LDLIBS_FILES := $(sort $(wildcard \
- $(addprefix $(RTE_OUTPUT)/lib/, \
-- $(patsubst -l%,lib%.a,$(filter -l%,$(LDLIBS)))))
-+ $(patsubst -l%,lib%.a,$(filter -l%,$(LDLIBS))))))
-
- #
- # Compile executable file if needed
-diff --git a/mk/rte.shared.mk b/mk/rte.shared.mk
-index 87ccf0ba4..4e680bc03 100644
---- a/mk/rte.shared.mk
-+++ b/mk/rte.shared.mk
-@@ -85,8 +85,8 @@ LDLIBS_NAMES += $(patsubst -Wl$(comma)-l%,lib%.a,$(filter -Wl$(comma)-l%,$(LDLIB
-
- # list of found libraries files (useful for deps). If not found, the
- # library is silently ignored and dep won't be checked
--LDLIBS_FILES := $(wildcard $(foreach dir,$(LDLIBS_PATH),\
-- $(addprefix $(dir)/,$(LDLIBS_NAMES))))
-+LDLIBS_FILES := $(sort $(wildcard $(foreach dir,$(LDLIBS_PATH),\
-+ $(addprefix $(dir)/,$(LDLIBS_NAMES)))))
-
- #
- # Archive objects in .so file if needed
---
-2.11.0
-
diff --git a/debian/patches/mk-sort-source-files-before-passing-them-to-the-comp.patch b/debian/patches/mk-sort-source-files-before-passing-them-to-the-comp.patch
deleted file mode 100644
index 02c95ae2..00000000
--- a/debian/patches/mk-sort-source-files-before-passing-them-to-the-comp.patch
+++ /dev/null
@@ -1,127 +0,0 @@
-Description: mk: sort source files before passing them to the compiler
-
-In order to achieve reproducible builds, always use the same
-order when listing files for compilation.
-
-Origin: http://dpdk.org/dev/patchwork/patch/27510/
-Forwarded: yes
-Author: Luca Boccassi <luca.boccassi@gmail.com>
-Last-Update: 2017-08-10
----
- drivers/net/cxgbe/Makefile | 2 +-
- drivers/net/e1000/Makefile | 2 +-
- drivers/net/fm10k/Makefile | 2 +-
- drivers/net/i40e/Makefile | 2 +-
- drivers/net/ixgbe/Makefile | 2 +-
- drivers/net/qede/Makefile | 2 +-
- drivers/net/sfc/Makefile | 2 +-
- drivers/net/thunderx/Makefile | 2 +-
- 8 files changed, 8 insertions(+), 8 deletions(-)
-
-diff --git a/drivers/net/cxgbe/Makefile b/drivers/net/cxgbe/Makefile
-index 7cef6279c..b4666b5af 100644
---- a/drivers/net/cxgbe/Makefile
-+++ b/drivers/net/cxgbe/Makefile
-@@ -67,7 +67,7 @@ endif
- # Add extra flags for base driver files (also known as shared code)
- # to disable warnings in them
- #
--BASE_DRIVER_OBJS=$(patsubst %.c,%.o,$(notdir $(wildcard $(SRCDIR)/base/*.c)))
-+BASE_DRIVER_OBJS=$(sort $(patsubst %.c,%.o,$(notdir $(wildcard $(SRCDIR)/base/*.c))))
- $(foreach obj, $(BASE_DRIVER_OBJS), $(eval CFLAGS_$(obj)+=$(CFLAGS_BASE_DRIVER)))
-
- VPATH += $(SRCDIR)/base
-diff --git a/drivers/net/e1000/Makefile b/drivers/net/e1000/Makefile
-index ffdf36d37..59d96bca1 100644
---- a/drivers/net/e1000/Makefile
-+++ b/drivers/net/e1000/Makefile
-@@ -68,7 +68,7 @@ endif
- # Add extra flags for base driver files (also known as shared code)
- # to disable warnings in them
- #
--BASE_DRIVER_OBJS=$(patsubst %.c,%.o,$(notdir $(wildcard $(SRCDIR)/base/*.c)))
-+BASE_DRIVER_OBJS=$(sort $(patsubst %.c,%.o,$(notdir $(wildcard $(SRCDIR)/base/*.c))))
- $(foreach obj, $(BASE_DRIVER_OBJS), $(eval CFLAGS_$(obj)+=$(CFLAGS_BASE_DRIVER)))
-
- VPATH += $(SRCDIR)/base
-diff --git a/drivers/net/fm10k/Makefile b/drivers/net/fm10k/Makefile
-index e0024f052..0bc124eb1 100644
---- a/drivers/net/fm10k/Makefile
-+++ b/drivers/net/fm10k/Makefile
-@@ -80,7 +80,7 @@ endif
- #
- # Add extra flags for base driver source files to disable warnings in them
- #
--BASE_DRIVER_OBJS=$(patsubst %.c,%.o,$(notdir $(wildcard $(SRCDIR)/base/*.c)))
-+BASE_DRIVER_OBJS=$(sort $(patsubst %.c,%.o,$(notdir $(wildcard $(SRCDIR)/base/*.c))))
- $(foreach obj, $(BASE_DRIVER_OBJS), $(eval CFLAGS_$(obj)+=$(CFLAGS_BASE_DRIVER)))
-
- VPATH += $(SRCDIR)/base
-diff --git a/drivers/net/i40e/Makefile b/drivers/net/i40e/Makefile
-index 56f210d6d..06eedc592 100644
---- a/drivers/net/i40e/Makefile
-+++ b/drivers/net/i40e/Makefile
-@@ -78,7 +78,7 @@ endif
-
- CFLAGS_i40e_lan_hmc.o += -Wno-error
- endif
--OBJS_BASE_DRIVER=$(patsubst %.c,%.o,$(notdir $(wildcard $(SRCDIR)/base/*.c)))
-+OBJS_BASE_DRIVER=$(sort $(patsubst %.c,%.o,$(notdir $(wildcard $(SRCDIR)/base/*.c))))
- $(foreach obj, $(OBJS_BASE_DRIVER), $(eval CFLAGS_$(obj)+=$(CFLAGS_BASE_DRIVER)))
-
- VPATH += $(SRCDIR)/base
-diff --git a/drivers/net/ixgbe/Makefile b/drivers/net/ixgbe/Makefile
-index 6a651b923..f5c370ce5 100644
---- a/drivers/net/ixgbe/Makefile
-+++ b/drivers/net/ixgbe/Makefile
-@@ -87,7 +87,7 @@ endif
- # Add extra flags for base driver files (also known as shared code)
- # to disable warnings in them
- #
--BASE_DRIVER_OBJS=$(patsubst %.c,%.o,$(notdir $(wildcard $(SRCDIR)/base/*.c)))
-+BASE_DRIVER_OBJS=$(sort $(patsubst %.c,%.o,$(notdir $(wildcard $(SRCDIR)/base/*.c))))
- $(foreach obj, $(BASE_DRIVER_OBJS), $(eval CFLAGS_$(obj)+=$(CFLAGS_BASE_DRIVER)))
-
- VPATH += $(SRCDIR)/base
-diff --git a/drivers/net/qede/Makefile b/drivers/net/qede/Makefile
-index f03441d9a..83ff95474 100644
---- a/drivers/net/qede/Makefile
-+++ b/drivers/net/qede/Makefile
-@@ -78,7 +78,7 @@ endif
- # to disable warnings in them
- #
- #
--BASE_DRIVER_OBJS=$(patsubst %.c,%.o,$(notdir $(wildcard $(SRCDIR)/base/*.c)))
-+BASE_DRIVER_OBJS=$(sort $(patsubst %.c,%.o,$(notdir $(wildcard $(SRCDIR)/base/*.c))))
- $(foreach obj, $(BASE_DRIVER_OBJS), $(eval CFLAGS_$(obj)+=$(CFLAGS_BASE_DRIVER)))
-
- VPATH += $(SRCDIR)/base
-diff --git a/drivers/net/sfc/Makefile b/drivers/net/sfc/Makefile
-index 57aa963ba..8cfd14d45 100644
---- a/drivers/net/sfc/Makefile
-+++ b/drivers/net/sfc/Makefile
-@@ -71,7 +71,7 @@ endif
- # List of base driver object files for which
- # special CFLAGS above should be applied
- #
--BASE_DRIVER_OBJS=$(patsubst %.c,%.o,$(notdir $(wildcard $(SRCDIR)/base/*.c)))
-+BASE_DRIVER_OBJS=$(sort $(patsubst %.c,%.o,$(notdir $(wildcard $(SRCDIR)/base/*.c))))
- $(foreach obj, $(BASE_DRIVER_OBJS), \
- $(eval CFLAGS_$(obj)+=$(CFLAGS_BASE_DRIVER)))
-
-diff --git a/drivers/net/thunderx/Makefile b/drivers/net/thunderx/Makefile
-index 706250b8b..ac384a624 100644
---- a/drivers/net/thunderx/Makefile
-+++ b/drivers/net/thunderx/Makefile
-@@ -45,7 +45,7 @@ EXPORT_MAP := rte_pmd_thunderx_nicvf_version.map
-
- LIBABIVER := 1
-
--OBJS_BASE_DRIVER=$(patsubst %.c,%.o,$(notdir $(wildcard $(SRCDIR)/base/*.c)))
-+OBJS_BASE_DRIVER=$(sort $(patsubst %.c,%.o,$(notdir $(wildcard $(SRCDIR)/base/*.c))))
- $(foreach obj, $(OBJS_BASE_DRIVER), $(eval CFLAGS_$(obj)+=$(CFLAGS_BASE_DRIVER)))
-
- VPATH += $(SRCDIR)/base
---
-2.11.0
-
diff --git a/debian/patches/series b/debian/patches/series
index 8426e7dd..5722b395 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1,7 +1 @@
fix-vhost-user-socket-permission.patch
-mk-sort-list-of-shared-objects-in-linker-script.patch
-mk-sort-list-of-files-in-examples.dox.patch
-mk-sort-headers-before-wildcard-inclusion.patch
-mk-sort-source-files-before-passing-them-to-the-comp.patch
-mk-sort-object-files-when-building-deps-lists.patch
-mk-install-symlinks-before-build-step.patch