aboutsummaryrefslogtreecommitdiffstats
path: root/debian
diff options
context:
space:
mode:
authorLuca Boccassi <luca.boccassi@gmail.com>2017-11-17 16:53:24 +0000
committerLuca Boccassi <luca.boccassi@gmail.com>2017-11-17 16:57:40 +0000
commit948da14fff4a29a046614871b74207a198ecdb4c (patch)
tree06c9907220ac1287e6eca899af6ac4a0ec59baad /debian
parent3384b36fc4d220bc62d05c352a09be89c2cda72f (diff)
Backport patch to link testpmd with virtio pmd
Change-Id: I06b7d54ca198ba82a326691391491542ae2eb3af Signed-off-by: Luca Boccassi <luca.boccassi@gmail.com>
Diffstat (limited to 'debian')
-rw-r--r--debian/patches/series1
-rw-r--r--debian/patches/testpmd-link-virtio.patch21
2 files changed, 22 insertions, 0 deletions
diff --git a/debian/patches/series b/debian/patches/series
index 5722b395..5034d58c 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1 +1,2 @@
fix-vhost-user-socket-permission.patch
+testpmd-link-virtio.patch
diff --git a/debian/patches/testpmd-link-virtio.patch b/debian/patches/testpmd-link-virtio.patch
new file mode 100644
index 00000000..8386f750
--- /dev/null
+++ b/debian/patches/testpmd-link-virtio.patch
@@ -0,0 +1,21 @@
+Description: app/testpmd: link with virtio PMD when using shared libraries
+ testpmd is often used inside a VM to test the OVS PVP scenario.
+ This commit makes testpmd to link to virtio PMD when DPDK is built as
+ shared libraries too.
+Origin: http://dpdk.org/dev/patchwork/patch/31459/
+Forwarded: yes
+Author: Timothy Redaelli <tredaelli@redhat.com>
+Last-Update: 2017-11-17
+--- a/app/test-pmd/Makefile
++++ b/app/test-pmd/Makefile
+@@ -91,6 +91,10 @@ ifeq ($(CONFIG_RTE_LIBRTE_PMD_SOFTNIC),y)
+ LDLIBS += -lrte_pmd_softnic
+ endif
+
++ifeq ($(CONFIG_RTE_LIBRTE_VIRTIO_PMD),y)
++LDLIBS += -lrte_pmd_virtio
++endif
++
+ endif
+
+ CFLAGS_cmdline.o := -D_GNU_SOURCE