aboutsummaryrefslogtreecommitdiffstats
path: root/debian
diff options
context:
space:
mode:
authorChristian Ehrhardt <christian.ehrhardt@canonical.com>2017-10-23 12:07:37 +0200
committerChristian Ehrhardt <christian.ehrhardt@canonical.com>2017-10-23 12:07:37 +0200
commitf27802a43419139be089eb7eccd7edac0e59daf4 (patch)
tree1f70124ec0822300a6e1d2e4a3158a4080d9d4b0 /debian
parent1fe21de4520923e56be8d8b252fa396cd8fb1af1 (diff)
d/rules: properly enable dpdk systemd service
Since ca40d310 "Convert debian/rules to new style DH targets" the installed service is by default disabled which is not intended. Add --with=systemd to dh, to issue the right sequence and be safe against future changes in that regard. Change-Id: I3d8be98397e59a3cc295368bf99fdf343d38419d Signed-off-by: Christian Ehrhardt <christian.ehrhardt@canonical.com>
Diffstat (limited to 'debian')
-rwxr-xr-xdebian/rules4
1 files changed, 2 insertions, 2 deletions
diff --git a/debian/rules b/debian/rules
index 3acd1210..49149c9c 100755
--- a/debian/rules
+++ b/debian/rules
@@ -121,11 +121,11 @@ build:
fi
sh debian/prep-modules $(KSRC)
cat debian/control.modules >> debian/control
- dh $@ --with python2,dkms
+ dh $@ --with python2,dkms,systemd
endif
%:
- dh $@ --with python2,dkms
+ dh $@ --with python2,dkms,systemd
override_dh_gencontrol:
dh_gencontrol