aboutsummaryrefslogtreecommitdiffstats
path: root/lib/librte_port/meson.build
diff options
context:
space:
mode:
authorChristian Ehrhardt <christian.ehrhardt@canonical.com>2018-06-01 09:09:08 +0200
committerChristian Ehrhardt <christian.ehrhardt@canonical.com>2018-06-01 09:12:07 +0200
commit1bd9b61222f3a81ffe770fc00b70ded6e760c42b (patch)
tree0bf7d996cf0664796687c1be6d22958fcf6a8096 /lib/librte_port/meson.build
parentbb4e158029645f37809fcf81a3acddd6fa11f88a (diff)
New upstream version 18.05
Change-Id: Icd4170ddc4f63aeae5d0559490e5195b5349f9c2 Signed-off-by: Christian Ehrhardt <christian.ehrhardt@canonical.com>
Diffstat (limited to 'lib/librte_port/meson.build')
-rw-r--r--lib/librte_port/meson.build12
1 files changed, 5 insertions, 7 deletions
diff --git a/lib/librte_port/meson.build b/lib/librte_port/meson.build
index debb5eb9..f3d8b443 100644
--- a/lib/librte_port/meson.build
+++ b/lib/librte_port/meson.build
@@ -5,23 +5,21 @@ version = 3
sources = files(
'rte_port_ethdev.c',
'rte_port_fd.c',
+ 'rte_port_frag.c',
+ 'rte_port_ras.c',
'rte_port_ring.c',
'rte_port_sched.c',
'rte_port_source_sink.c')
headers = files(
'rte_port_ethdev.h',
'rte_port_fd.h',
+ 'rte_port_frag.h',
+ 'rte_port_ras.h',
'rte_port.h',
'rte_port_ring.h',
'rte_port_sched.h',
'rte_port_source_sink.h')
-deps += ['ethdev', 'sched']
-
-if dpdk_conf.has('RTE_LIBRTE_IP_FRAG')
- sources += files('rte_port_frag.c', 'rte_port_ras.c')
- headers += files('rte_port_frag.h', 'rte_port_ras.h')
- deps += ['ip_frag']
-endif
+deps += ['ethdev', 'sched', 'ip_frag']
if dpdk_conf.has('RTE_LIBRTE_KNI')
sources += files('rte_port_kni.c')