summaryrefslogtreecommitdiffstats
path: root/lib/librte_port/meson.build
diff options
context:
space:
mode:
authorLuca Boccassi <luca.boccassi@gmail.com>2018-02-19 11:18:57 +0000
committerLuca Boccassi <luca.boccassi@gmail.com>2018-02-19 11:19:06 +0000
commit126425ac3cc7e0b2f894047c2e58b2659a13e6c6 (patch)
tree165c66b8f1e8e9a4badf772668995a1b712a790d /lib/librte_port/meson.build
parent5b3db0f8f1ad5ba2152d977ccd3825ea05e863a2 (diff)
parentca33590b6af032bff57d9cc70455660466a654b2 (diff)
Merge tag 'upstream/18.02' into 18.02.x
Upstream version 18.02 Change-Id: I2e8995eb3fee86cbc3004bdfacd72ef4e17098c0 Signed-off-by: Luca Boccassi <luca.boccassi@gmail.com>
Diffstat (limited to 'lib/librte_port/meson.build')
-rw-r--r--lib/librte_port/meson.build30
1 files changed, 30 insertions, 0 deletions
diff --git a/lib/librte_port/meson.build b/lib/librte_port/meson.build
new file mode 100644
index 00000000..debb5eb9
--- /dev/null
+++ b/lib/librte_port/meson.build
@@ -0,0 +1,30 @@
+# SPDX-License-Identifier: BSD-3-Clause
+# Copyright(c) 2017 Intel Corporation
+
+version = 3
+sources = files(
+ 'rte_port_ethdev.c',
+ 'rte_port_fd.c',
+ 'rte_port_ring.c',
+ 'rte_port_sched.c',
+ 'rte_port_source_sink.c')
+headers = files(
+ 'rte_port_ethdev.h',
+ 'rte_port_fd.h',
+ 'rte_port.h',
+ 'rte_port_ring.h',
+ 'rte_port_sched.h',
+ 'rte_port_source_sink.h')
+deps += ['ethdev', 'sched']
+
+if dpdk_conf.has('RTE_LIBRTE_IP_FRAG')
+ sources += files('rte_port_frag.c', 'rte_port_ras.c')
+ headers += files('rte_port_frag.h', 'rte_port_ras.h')
+ deps += ['ip_frag']
+endif
+
+if dpdk_conf.has('RTE_LIBRTE_KNI')
+ sources += files('rte_port_kni.c')
+ headers += files('rte_port_kni.h')
+ deps += 'kni'
+endif