summaryrefslogtreecommitdiffstats
path: root/lib/librte_port/meson.build
diff options
context:
space:
mode:
authorLuca Boccassi <luca.boccassi@gmail.com>2018-08-14 18:52:30 +0100
committerLuca Boccassi <luca.boccassi@gmail.com>2018-08-14 18:53:17 +0100
commitb63264c8342e6a1b6971c79550d2af2024b6a4de (patch)
tree83114aac64286fe616506c0b3dfaec2ab86ef835 /lib/librte_port/meson.build
parentca33590b6af032bff57d9cc70455660466a654b2 (diff)
New upstream version 18.08upstream/18.08
Change-Id: I32fdf5e5016556d9c0a6d88ddaf1fc468961790a Signed-off-by: Luca Boccassi <luca.boccassi@gmail.com>
Diffstat (limited to 'lib/librte_port/meson.build')
-rw-r--r--lib/librte_port/meson.build12
1 files changed, 5 insertions, 7 deletions
diff --git a/lib/librte_port/meson.build b/lib/librte_port/meson.build
index debb5eb9..f3d8b443 100644
--- a/lib/librte_port/meson.build
+++ b/lib/librte_port/meson.build
@@ -5,23 +5,21 @@ version = 3
sources = files(
'rte_port_ethdev.c',
'rte_port_fd.c',
+ 'rte_port_frag.c',
+ 'rte_port_ras.c',
'rte_port_ring.c',
'rte_port_sched.c',
'rte_port_source_sink.c')
headers = files(
'rte_port_ethdev.h',
'rte_port_fd.h',
+ 'rte_port_frag.h',
+ 'rte_port_ras.h',
'rte_port.h',
'rte_port_ring.h',
'rte_port_sched.h',
'rte_port_source_sink.h')
-deps += ['ethdev', 'sched']
-
-if dpdk_conf.has('RTE_LIBRTE_IP_FRAG')
- sources += files('rte_port_frag.c', 'rte_port_ras.c')
- headers += files('rte_port_frag.h', 'rte_port_ras.h')
- deps += ['ip_frag']
-endif
+deps += ['ethdev', 'sched', 'ip_frag']
if dpdk_conf.has('RTE_LIBRTE_KNI')
sources += files('rte_port_kni.c')