aboutsummaryrefslogtreecommitdiffstats
path: root/debian/patches/dpdk-dev-ppc-enable-2-7-acl-add-AltiVec-for-ppc64.patch
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/dpdk-dev-ppc-enable-2-7-acl-add-AltiVec-for-ppc64.patch')
-rw-r--r--debian/patches/dpdk-dev-ppc-enable-2-7-acl-add-AltiVec-for-ppc64.patch37
1 files changed, 7 insertions, 30 deletions
diff --git a/debian/patches/dpdk-dev-ppc-enable-2-7-acl-add-AltiVec-for-ppc64.patch b/debian/patches/dpdk-dev-ppc-enable-2-7-acl-add-AltiVec-for-ppc64.patch
index fad0a71e..d8bf464b 100644
--- a/debian/patches/dpdk-dev-ppc-enable-2-7-acl-add-AltiVec-for-ppc64.patch
+++ b/debian/patches/dpdk-dev-ppc-enable-2-7-acl-add-AltiVec-for-ppc64.patch
@@ -25,11 +25,9 @@ Last-Update: 2016-09-21
create mode 100644 lib/librte_acl/acl_run_altivec.c
create mode 100644 lib/librte_acl/acl_run_altivec.h
-diff --git a/app/test-acl/main.c b/app/test-acl/main.c
-index d366981..1b2b176 100644
--- a/app/test-acl/main.c
+++ b/app/test-acl/main.c
-@@ -105,6 +105,10 @@ static const struct acl_alg acl_alg[] = {
+@@ -105,6 +105,10 @@
.name = "neon",
.alg = RTE_ACL_CLASSIFY_NEON,
},
@@ -40,11 +38,9 @@ index d366981..1b2b176 100644
};
static struct {
-diff --git a/config/defconfig_ppc_64-power8-linuxapp-gcc b/config/defconfig_ppc_64-power8-linuxapp-gcc
-index 9ddf3c5..dede34f 100644
--- a/config/defconfig_ppc_64-power8-linuxapp-gcc
+++ b/config/defconfig_ppc_64-power8-linuxapp-gcc
-@@ -57,7 +57,6 @@ CONFIG_RTE_LIBRTE_ENIC_PMD=n
+@@ -56,7 +56,6 @@
CONFIG_RTE_LIBRTE_FM10K_PMD=n
# This following libraries are not available on Power. So they're turned off.
@@ -52,11 +48,9 @@ index 9ddf3c5..dede34f 100644
CONFIG_RTE_LIBRTE_SCHED=n
CONFIG_RTE_LIBRTE_PORT=n
CONFIG_RTE_LIBRTE_TABLE=n
-diff --git a/lib/librte_acl/Makefile b/lib/librte_acl/Makefile
-index 9803e9d..d05be66 100644
--- a/lib/librte_acl/Makefile
+++ b/lib/librte_acl/Makefile
-@@ -52,6 +52,8 @@ SRCS-$(CONFIG_RTE_LIBRTE_ACL) += acl_run_scalar.c
+@@ -52,6 +52,8 @@
ifneq ($(filter y,$(CONFIG_RTE_ARCH_ARM) $(CONFIG_RTE_ARCH_ARM64)),)
SRCS-$(CONFIG_RTE_LIBRTE_ACL) += acl_run_neon.c
CFLAGS_acl_run_neon.o += -flax-vector-conversions -Wno-maybe-uninitialized
@@ -65,11 +59,9 @@ index 9803e9d..d05be66 100644
else
SRCS-$(CONFIG_RTE_LIBRTE_ACL) += acl_run_sse.c
#check if flag for SSE4.1 is already on, if not set it up manually
-diff --git a/lib/librte_acl/acl.h b/lib/librte_acl/acl.h
-index 09d6784..6664a55 100644
--- a/lib/librte_acl/acl.h
+++ b/lib/librte_acl/acl.h
-@@ -234,6 +234,10 @@ int
+@@ -234,6 +234,10 @@
rte_acl_classify_neon(const struct rte_acl_ctx *ctx, const uint8_t **data,
uint32_t *results, uint32_t num, uint32_t categories);
@@ -80,8 +72,6 @@ index 09d6784..6664a55 100644
#ifdef __cplusplus
}
#endif /* __cplusplus */
-diff --git a/lib/librte_acl/acl_run.h b/lib/librte_acl/acl_run.h
-index b2fc42c..024f393 100644
--- a/lib/librte_acl/acl_run.h
+++ b/lib/librte_acl/acl_run.h
@@ -39,7 +39,9 @@
@@ -94,9 +84,6 @@ index b2fc42c..024f393 100644
#define MAX_SEARCHES_SCALAR 2
#define GET_NEXT_4BYTES(prm, idx) \
-diff --git a/lib/librte_acl/acl_run_altivec.c b/lib/librte_acl/acl_run_altivec.c
-new file mode 100644
-index 0000000..3523526
--- /dev/null
+++ b/lib/librte_acl/acl_run_altivec.c
@@ -0,0 +1,47 @@
@@ -147,9 +134,6 @@ index 0000000..3523526
+ return rte_acl_classify_scalar(ctx, data, results, num,
+ categories);
+}
-diff --git a/lib/librte_acl/acl_run_altivec.h b/lib/librte_acl/acl_run_altivec.h
-new file mode 100644
-index 0000000..7d329bc
--- /dev/null
+++ b/lib/librte_acl/acl_run_altivec.h
@@ -0,0 +1,329 @@
@@ -482,11 +466,9 @@ index 0000000..7d329bc
+
+ return 0;
+}
-diff --git a/lib/librte_acl/rte_acl.c b/lib/librte_acl/rte_acl.c
-index 4ba9786..8b7e92c 100644
--- a/lib/librte_acl/rte_acl.c
+++ b/lib/librte_acl/rte_acl.c
-@@ -75,12 +75,23 @@ rte_acl_classify_neon(__rte_unused const struct rte_acl_ctx *ctx,
+@@ -75,12 +75,23 @@
return -ENOTSUP;
}
@@ -510,7 +492,7 @@ index 4ba9786..8b7e92c 100644
};
/* by default, use always available scalar code path. */
-@@ -119,6 +130,8 @@ rte_acl_init(void)
+@@ -119,6 +130,8 @@
#elif defined(RTE_ARCH_ARM)
if (rte_cpu_get_flag_enabled(RTE_CPUFLAG_NEON))
alg = RTE_ACL_CLASSIFY_NEON;
@@ -519,11 +501,9 @@ index 4ba9786..8b7e92c 100644
#else
#ifdef CC_AVX2_SUPPORT
if (rte_cpu_get_flag_enabled(RTE_CPUFLAG_AVX2))
-diff --git a/lib/librte_acl/rte_acl.h b/lib/librte_acl/rte_acl.h
-index 0979a09..8d4e2a6 100644
--- a/lib/librte_acl/rte_acl.h
+++ b/lib/librte_acl/rte_acl.h
-@@ -271,6 +271,7 @@ enum rte_acl_classify_alg {
+@@ -271,6 +271,7 @@
RTE_ACL_CLASSIFY_SSE = 2, /**< requires SSE4.1 support. */
RTE_ACL_CLASSIFY_AVX2 = 3, /**< requires AVX2 support. */
RTE_ACL_CLASSIFY_NEON = 4, /**< requires NEON support. */
@@ -531,6 +511,3 @@ index 0979a09..8d4e2a6 100644
RTE_ACL_CLASSIFY_NUM /* should always be the last one. */
};
---
-1.9.1
-