summaryrefslogtreecommitdiffstats
path: root/debian/patches/dpdk-dev-v2-2-4-doc-rendering-and-installation-of-man-pages.patch
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/dpdk-dev-v2-2-4-doc-rendering-and-installation-of-man-pages.patch')
-rw-r--r--debian/patches/dpdk-dev-v2-2-4-doc-rendering-and-installation-of-man-pages.patch56
1 files changed, 56 insertions, 0 deletions
diff --git a/debian/patches/dpdk-dev-v2-2-4-doc-rendering-and-installation-of-man-pages.patch b/debian/patches/dpdk-dev-v2-2-4-doc-rendering-and-installation-of-man-pages.patch
new file mode 100644
index 00000000..f2e307f1
--- /dev/null
+++ b/debian/patches/dpdk-dev-v2-2-4-doc-rendering-and-installation-of-man-pages.patch
@@ -0,0 +1,56 @@
+diff --git a/doc/guides/conf.py b/doc/guides/conf.py
+index cd6a4f7..55b6b2f 100644
+--- a/doc/guides/conf.py
++++ b/doc/guides/conf.py
+@@ -105,6 +105,14 @@ class CustomLatexFormatter(LatexFormatter):
+ # Replace the default latex formatter.
+ PygmentsBridge.latex_formatter = CustomLatexFormatter
+
++# Configuration for man pages
++man_pages = [("testpmd_app_ug/run_app", "testpmd",
++ "tests for dpdk pmds", "", 1),
++ ("tools/pdump", "dpdk-pdump",
++ "enable packet capture on dpdk ports", "", 1),
++ ("tools/proc_info", "dpdk-procinfo",
++ "access dpdk port stats and memory info", "", 1)]
++
+ ######## :numref: fallback ########
+ # The following hook functions add some simple handling for the :numref:
+ # directive for Sphinx versions prior to 1.3.1. The functions replace the
+diff --git a/mk/rte.sdkdoc.mk b/mk/rte.sdkdoc.mk
+index 9952f25..21d9bdf 100644
+--- a/mk/rte.sdkdoc.mk
++++ b/mk/rte.sdkdoc.mk
+@@ -63,7 +63,7 @@ help:
+ all: api-html guides-html guides-pdf
+
+ .PHONY: clean
+-clean: api-html-clean guides-html-clean guides-pdf-clean
++clean: api-html-clean guides-html-clean guides-pdf-clean guides-man-clean
+
+ .PHONY: api-html
+ api-html: api-html-clean
+diff --git a/mk/rte.sdkinstall.mk b/mk/rte.sdkinstall.mk
+index 5217063..533d369 100644
+--- a/mk/rte.sdkinstall.mk
++++ b/mk/rte.sdkinstall.mk
+@@ -66,6 +66,7 @@ includedir ?= $(prefix)/include/dpdk
+ datarootdir ?= $(prefix)/share
+ docdir ?= $(datarootdir)/doc/dpdk
+ datadir ?= $(datarootdir)/dpdk
++mandir ?= $(datarootdir)/man
+ sdkdir ?= $(datadir)
+ targetdir ?= $(datadir)/$(RTE_TARGET)
+
+@@ -133,6 +134,11 @@ install-runtime:
+ $(DESTDIR)$(sbindir)/dpdk-devbind)
+ $(Q)$(call rte_symlink, $(DESTDIR)$(datadir)/tools/dpdk-pmdinfo.py, \
+ $(DESTDIR)$(bindir)/dpdk-pmdinfo)
++ifneq ($(wildcard $O/doc/man/*/*.1),)
++ $(Q)$(call rte_mkdir, $(DESTDIR)$(mandir))
++ $(Q)$(call rte_mkdir, $(DESTDIR)$(mandir)/man1)
++ $(Q)cp -a $O/doc/man/*/*.1 $(DESTDIR)$(mandir)/man1
++endif
+
+ install-kmod:
+ ifneq ($(wildcard $O/kmod/*),)