aboutsummaryrefslogtreecommitdiffstats
path: root/debian/patches/mk-use-make-silent-flag-to-print-HTML-doc-version.patch
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/mk-use-make-silent-flag-to-print-HTML-doc-version.patch')
-rw-r--r--debian/patches/mk-use-make-silent-flag-to-print-HTML-doc-version.patch31
1 files changed, 31 insertions, 0 deletions
diff --git a/debian/patches/mk-use-make-silent-flag-to-print-HTML-doc-version.patch b/debian/patches/mk-use-make-silent-flag-to-print-HTML-doc-version.patch
new file mode 100644
index 00000000..77a248bb
--- /dev/null
+++ b/debian/patches/mk-use-make-silent-flag-to-print-HTML-doc-version.patch
@@ -0,0 +1,31 @@
+Description: mk: use make silent flag to print HTML doc version
+
+Depending on the environment, make might echo the command being ran.
+In mk/rte.sdkdoc.mk make is used to print the DPDK version to be
+piped to doxygen. This causes the following to be written:
+
+<div id="projectname">DPDK
+&#160;<span id="projectnumber">/usr/bin/make-f/build/dpdk-jYjqnr/dpdk-16.11.2/mk/rte.sdkconfig.mkshowversion</span>
+</div>
+
+Use -s (--silent) to prevent echoing.
+
+Origin: http://dpdk.org/dev/patchwork/patch/25673/
+Forwarded: yes
+Author: Luca Boccassi <luca.boccassi@gmail.com>
+Last-Update: 2017-06-24
+---
+ mk/rte.sdkdoc.mk | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+--- a/mk/rte.sdkdoc.mk
++++ b/mk/rte.sdkdoc.mk
+@@ -71,7 +71,7 @@ api-html: api-html-clean
+ $(Q)mkdir -p $(RTE_OUTPUT)/doc/html
+ $(Q)(cat $(RTE_SDK)/doc/api/doxy-api.conf && \
+ printf 'PROJECT_NUMBER = ' && \
+- $(MAKE) -rR showversion && \
++ $(MAKE) -rRs showversion && \
+ echo OUTPUT_DIRECTORY = $(RTE_OUTPUT)/doc && \
+ echo HTML_OUTPUT = html/api && \
+ echo GENERATE_HTML = YES && \