aboutsummaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rw-r--r--[-rwxr-xr-x]debian/rules14
1 files changed, 8 insertions, 6 deletions
diff --git a/debian/rules b/debian/rules
index 9d2d3b91..4d171885 100755..100644
--- a/debian/rules
+++ b/debian/rules
@@ -176,6 +176,7 @@ endif
ifeq (,$(filter dpdk_config=%,$(DEB_BUILD_OPTIONS)))
sed -ri -e 's,(RTE_MACHINE=).*,\1$(RTE_MACHINE),' \
-e 's,(RTE_NEXT_ABI=).*,\1n,' \
+ -e 's,(CONFIG_RTE_MAJOR_ABI=).*,\1$(DPDK_ABI),' \
-e 's,(CONFIG_RTE_EAL_IGB_UIO=).*,\1$(DPDK_CONFIG_BUILD_KMOD),' \
-e 's,(CONFIG_RTE_KNI_KMOD=).*,\1$(DPDK_CONFIG_BUILD_KMOD),' \
-e 's,(LIBRTE_PMD_PCAP=).*,\1y,' \
@@ -251,8 +252,10 @@ endif
debian/dpdk-dev/usr/share/dpdk/dpdk-sdk-env.sh
# include the bundled autotest suite to be usable from the dpdk-dev package
mkdir -p debian/dpdk-dev/usr/share/dpdk/test
- cp -a app/test/autotest* debian/dpdk-dev/usr/share/dpdk/test
+ cp -a test/test/autotest* debian/dpdk-dev/usr/share/dpdk/test
cp $(DPDK_SHARED_DIR)/app/test debian/dpdk-dev/usr/share/dpdk/test/
+ cp $(DPDK_SHARED_DIR)/app/testacl debian/dpdk-dev/usr/share/dpdk/test/
+ cp $(DPDK_SHARED_DIR)/app/testpipeline debian/dpdk-dev/usr/share/dpdk/test/
# since we move libs to multiarch dirs update the non aware symlink
rm debian/dpdk-dev/usr/share/dpdk/$(RTE_TARGET)/lib
ln -rs debian/dpdk-dev/$(LIBDIR)/ \
@@ -276,16 +279,15 @@ endif
# Package(s): libdpdk-<NAME><VER> (bare runtime libs)
for lib in $$(ls -1 debian/dpdk/$(LIBDIR)/*.so.*); do \
BN=$$(basename $${lib}); \
- VER=$$(echo $${BN} | sed -e 's/^.*\.so\.//'); \
- LN=$$(echo $${BN} | sed -e 's/\.so\.[0-9]*$$//' | tr '_' '-'); \
+ LN=$$(echo $${BN} | sed -e 's/\.so\.[0-9\.]*$$//' | tr '_' '-'); \
if echo $${LN} | grep -q ".*[0-9]$$"; then \
- PKG=$${LN}-$${VER}; \
+ PKG=$${LN}-$(VERSION); \
else \
- PKG=$${LN}$${VER}; \
+ PKG=$${LN}$(VERSION); \
fi; \
LIBF="$$(basename $${lib})"; \
LIBD="debian/$${PKG}/$(LIBDIR)"; \
- echo "moving $${lib} for library $${PKG}"; \
+ echo "moving $${lib} to dir $${LIBD} (PKG=$${PKG} BN=$${BN} LN={$${LN} LIBF=$${LIBF} LIBD=$${LIBD})"; \
mkdir -p $${LIBD}; \
mv $${lib} $${LIBD}; \
if [ "$${LIBF#librte_pmd_}x" != "$${LIBF}x" ]; then \