aboutsummaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules10
1 files changed, 10 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index 954c716c..e05f332f 100755
--- a/debian/rules
+++ b/debian/rules
@@ -167,6 +167,7 @@ override_dh_auto_clean:
sed -i '/Package: dpdk-modules-/,/`tail -n1 debian/control.modules.in`/d' debian/control
test -L config/defconfig_$(DPDK_CONFIG) && rm -f config/defconfig_$(DPDK_CONFIG) || true
rm -f debian/dpdk-igb-uio-dkms.dkms debian/dpdk-rte-kni-dkms.dkms
+ rm -f debian/dpdk-dev.preinst
override_dh_auto_configure:
# Add support for a custom defconfig file in the debian directory.
@@ -279,11 +280,20 @@ endif
# system installs them in the same directory, breaking multiarch.
# Move them in /usr/include/<arch>/dpdk instead.
mkdir -p debian/libdpdk-dev/usr/include/$(DEB_HOST_MULTIARCH)/dpdk
+ # Before moving the files, remove the symlink in usr/share/dpdk and copy them over,
+ # as the SDK subdir is architecture specific and requires the arch-specific headers
+ # in the top level
+ rm -f debian/dpdk-dev/usr/share/dpdk/$(RTE_TARGET)/include
+ mkdir -p debian/dpdk-dev/usr/share/dpdk/$(RTE_TARGET)/include
+ cp -r debian/dpdk-dev/usr/include/dpdk/* debian/dpdk-dev/usr/share/dpdk/$(RTE_TARGET)/include
+ # genereate the preinst to deal with the symlink -> directory transition smoothly
+ sed "s/@@RTE_TARGET@@/$(RTE_TARGET)/g" debian/dpdk-dev.preinst.in > debian/dpdk-dev.preinst
mv $(addprefix debian/dpdk-dev/usr/include/dpdk/,$(notdir $(wildcard lib/librte_eal/common/include/arch/$(INCLUDE_ARCH)/*.h))) \
debian/libdpdk-dev/usr/include/$(DEB_HOST_MULTIARCH)/dpdk/
mv debian/dpdk-dev/usr/include/dpdk/rte_config.h \
debian/libdpdk-dev/usr/include/$(DEB_HOST_MULTIARCH)/dpdk/
mv debian/dpdk-dev/usr/include/dpdk debian/libdpdk-dev/usr/include/
+ rmdir debian/dpdk-dev/usr/include
# backward compatibility: to ease things for the majority of users,
# which are on x86_64, symlink the x86 headers into the global
# directory.