aboutsummaryrefslogtreecommitdiffstats
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/control6
-rwxr-xr-xdebian/rules4
2 files changed, 5 insertions, 5 deletions
diff --git a/debian/control b/debian/control
index 59e2fa02..297c3b03 100644
--- a/debian/control
+++ b/debian/control
@@ -33,7 +33,7 @@ Depends: hwdata,
lsb-base (>= 3.2-14),
pciutils,
${misc:Depends},
- ${python:Depends},
+ ${python3:Depends},
${shlibs:Depends}
Recommends: ${librte:Recommends},
Suggests: dpdk-doc,
@@ -63,8 +63,8 @@ Section: doc
Architecture: all
Multi-Arch: foreign
Homepage: http://dpdk.org/doc/guides/index.html
-Depends: libjs-jquery, libjs-underscore, ${misc:Depends}, ${python:Depends}
-Recommends: python, ${python:Recommends}
+Depends: libjs-jquery, libjs-underscore, ${misc:Depends}, ${python3:Depends}
+Recommends: python3, ${python3:Recommends}
Description: Data Plane Development Kit (documentation)
DPDK is a set of libraries for fast packet processing. Applications run
in user-space and communicate directly with dedicated network interfaces.
diff --git a/debian/rules b/debian/rules
index 0296b80d..4ae33c8a 100755
--- a/debian/rules
+++ b/debian/rules
@@ -121,11 +121,11 @@ build:
fi
sh debian/prep-modules $(KSRC)
cat debian/control.modules >> debian/control
- dh $@ --with python2,dkms,systemd
+ dh $@ --with python3,dkms,systemd
endif
%:
- dh $@ --with python2,dkms,systemd
+ dh $@ --with python3,dkms,systemd
override_dh_gencontrol:
dh_gencontrol