aboutsummaryrefslogtreecommitdiffstats
path: root/drivers/common/dpaax/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'drivers/common/dpaax/meson.build')
-rw-r--r--drivers/common/dpaax/meson.build12
1 files changed, 12 insertions, 0 deletions
diff --git a/drivers/common/dpaax/meson.build b/drivers/common/dpaax/meson.build
new file mode 100644
index 00000000..98a1bdd4
--- /dev/null
+++ b/drivers/common/dpaax/meson.build
@@ -0,0 +1,12 @@
+# SPDX-License-Identifier: BSD-3-Clause
+# Copyright(c) 2018 NXP
+
+allow_experimental_apis = true
+
+if host_machine.system() != 'linux'
+ build = false
+endif
+
+sources = files('dpaax_iova_table.c')
+
+cflags += ['-D_GNU_SOURCE']