aboutsummaryrefslogtreecommitdiffstats
path: root/drivers/crypto/aesni_mb/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'drivers/crypto/aesni_mb/meson.build')
-rw-r--r--drivers/crypto/aesni_mb/meson.build12
1 files changed, 12 insertions, 0 deletions
diff --git a/drivers/crypto/aesni_mb/meson.build b/drivers/crypto/aesni_mb/meson.build
new file mode 100644
index 00000000..aae0995e
--- /dev/null
+++ b/drivers/crypto/aesni_mb/meson.build
@@ -0,0 +1,12 @@
+# SPDX-License-Identifier: BSD-3-Clause
+# Copyright(c) 2018 Intel Corporation
+
+lib = cc.find_library('IPSec_MB', required: false)
+if not lib.found()
+ build = false
+else
+ ext_deps += lib
+endif
+
+sources = files('rte_aesni_mb_pmd.c', 'rte_aesni_mb_pmd_ops.c')
+deps += ['bus_vdev']