aboutsummaryrefslogtreecommitdiffstats
path: root/drivers/crypto/dpaa2_sec/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'drivers/crypto/dpaa2_sec/meson.build')
-rw-r--r--drivers/crypto/dpaa2_sec/meson.build14
1 files changed, 14 insertions, 0 deletions
diff --git a/drivers/crypto/dpaa2_sec/meson.build b/drivers/crypto/dpaa2_sec/meson.build
new file mode 100644
index 00000000..01afc587
--- /dev/null
+++ b/drivers/crypto/dpaa2_sec/meson.build
@@ -0,0 +1,14 @@
+# SPDX-License-Identifier: BSD-3-Clause
+# Copyright 2018 NXP
+
+if host_machine.system() != 'linux'
+ build = false
+endif
+
+deps += ['security', 'mempool_dpaa2']
+sources = files('dpaa2_sec_dpseci.c',
+ 'mc/dpseci.c')
+
+allow_experimental_apis = true
+
+includes += include_directories('mc', 'hw')