aboutsummaryrefslogtreecommitdiffstats
path: root/drivers/crypto/openssl/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'drivers/crypto/openssl/meson.build')
-rw-r--r--drivers/crypto/openssl/meson.build11
1 files changed, 11 insertions, 0 deletions
diff --git a/drivers/crypto/openssl/meson.build b/drivers/crypto/openssl/meson.build
new file mode 100644
index 00000000..c2a0dd8b
--- /dev/null
+++ b/drivers/crypto/openssl/meson.build
@@ -0,0 +1,11 @@
+# SPDX-License-Identifier: BSD-3-Clause
+# Copyright(c) 2017 Intel Corporation
+
+dep = dependency('libcrypto', required: false)
+if not dep.found()
+ build = false
+endif
+deps += 'bus_vdev'
+sources = files('rte_openssl_pmd.c', 'rte_openssl_pmd_ops.c')
+ext_deps += dep
+pkgconfig_extra_libs += '-lcrypto'