aboutsummaryrefslogtreecommitdiffstats
path: root/drivers/crypto/zuc/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'drivers/crypto/zuc/meson.build')
-rw-r--r--drivers/crypto/zuc/meson.build12
1 files changed, 12 insertions, 0 deletions
diff --git a/drivers/crypto/zuc/meson.build b/drivers/crypto/zuc/meson.build
new file mode 100644
index 00000000..b8ca7107
--- /dev/null
+++ b/drivers/crypto/zuc/meson.build
@@ -0,0 +1,12 @@
+# SPDX-License-Identifier: BSD-3-Clause
+# Copyright(c) 2018 Intel Corporation
+
+lib = cc.find_library('libsso_zuc', required: false)
+if not lib.found()
+ build = false
+else
+ ext_deps += lib
+endif
+
+sources = files('rte_zuc_pmd.c', 'rte_zuc_pmd_ops.c')
+deps += ['bus_vdev']