aboutsummaryrefslogtreecommitdiffstats
path: root/drivers/event/dpaa2/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'drivers/event/dpaa2/meson.build')
-rw-r--r--drivers/event/dpaa2/meson.build11
1 files changed, 11 insertions, 0 deletions
diff --git a/drivers/event/dpaa2/meson.build b/drivers/event/dpaa2/meson.build
new file mode 100644
index 00000000..de7a4615
--- /dev/null
+++ b/drivers/event/dpaa2/meson.build
@@ -0,0 +1,11 @@
+# SPDX-License-Identifier: BSD-3-Clause
+# Copyright 2018 NXP
+
+if host_machine.system() != 'linux'
+ build = false
+endif
+deps += ['bus_vdev', 'pmd_dpaa2']
+sources = files('dpaa2_hw_dpcon.c',
+ 'dpaa2_eventdev.c')
+
+allow_experimental_apis = true