aboutsummaryrefslogtreecommitdiffstats
path: root/drivers/mempool/dpaa2/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'drivers/mempool/dpaa2/meson.build')
-rw-r--r--drivers/mempool/dpaa2/meson.build12
1 files changed, 12 insertions, 0 deletions
diff --git a/drivers/mempool/dpaa2/meson.build b/drivers/mempool/dpaa2/meson.build
new file mode 100644
index 00000000..90bab606
--- /dev/null
+++ b/drivers/mempool/dpaa2/meson.build
@@ -0,0 +1,12 @@
+# SPDX-License-Identifier: BSD-3-Clause
+# Copyright 2018 NXP
+
+if host_machine.system() != 'linux'
+ build = false
+endif
+
+deps += ['bus_fslmc']
+sources = files('dpaa2_hw_mempool.c')
+
+# depends on fslmc bus which uses experimental API
+allow_experimental_apis = true