aboutsummaryrefslogtreecommitdiffstats
path: root/drivers/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'drivers/meson.build')
-rw-r--r--drivers/meson.build19
1 files changed, 15 insertions, 4 deletions
diff --git a/drivers/meson.build b/drivers/meson.build
index f94e2fe6..c3c66bbc 100644
--- a/drivers/meson.build
+++ b/drivers/meson.build
@@ -9,12 +9,17 @@ driver_classes = ['common',
'crypto', # depends on common, bus and mempool (net in future).
'compress', # depends on common, bus, mempool.
'event', # depends on common, bus, mempool and net.
+ 'baseband', # depends on common and bus.
'raw'] # depends on common, bus, mempool, net and event.
default_cflags = machine_args
if cc.has_argument('-Wno-format-truncation')
default_cflags += '-Wno-format-truncation'
endif
+
+# specify -D_GNU_SOURCE unconditionally
+default_cflags += '-D_GNU_SOURCE'
+
foreach class:driver_classes
drivers = []
std_deps = []
@@ -24,6 +29,7 @@ foreach class:driver_classes
# version file for linking
subdir(class)
+ class_drivers = []
foreach drv:drivers
drv_path = join_paths(class, drv)
@@ -51,6 +57,8 @@ foreach class:driver_classes
subdir(drv_path)
if build
+ class_drivers += name
+
dpdk_conf.set(config_flag_fmt.format(name.to_upper()),1)
lib_name = driver_name_fmt.format(name)
@@ -94,10 +102,8 @@ foreach class:driver_classes
lib_version = '@0@.1'.format(version)
so_version = '@0@'.format(version)
else
- pver = meson.project_version().split('.')
- lib_version = '@0@.@1@'.format(pver.get(0),
- pver.get(1))
- so_version = lib_version
+ lib_version = major_version
+ so_version = major_version
endif
# now build the static driver
@@ -141,4 +147,9 @@ foreach class:driver_classes
set_variable('static_@0@'.format(lib_name), static_dep)
endif # build
endforeach
+
+ if meson.version().version_compare('>=0.47')
+ # prior to 0.47, set_variable can't take array params
+ set_variable(class + '_drivers', class_drivers)
+ endif
endforeach